Open the console of an android node on windows (same LAN)


I use an android node to sync to different other nodes in my network. How can I access the Syncthing console of that android node from my windows workstation?

What I have tried:

  • Ping the android node from windows workstation → OK
  • Accessing http://-android node IP-:8384/# from the windows node → timeout
  • Accessing the local console on the android node via browser → OK

Can anyone please give me an advice?

PS. I can access the android node via a remote desktop software (like ScrCpy or TeamViewer), but that is quite unhandy.

PPS. The browser on my windows workstation has granted unlimited network access to the network in its firewall.

You need to change the address on Android to This needs to be done in the app settings, not in the Web GUI. Also, you cannot change the login and password, which default to syncthing and the API key respectively.

Thank you @tomasz86

I got the login screen and could pass it with the given credentials. But after that, the browser of the windows workstation returns a ERR_CONNECTION_REFUSED message. I can not reach the GUI.

If trying to reach on the android node itself (local), a white page with the text Host check error apperas.

Just to make sure, is this what you have done, and then restarted Syncthing from within the app?

If yes, then you really should be just able to connect remotely by typing the IP address and the port, e.g., etc. If this doesn’t work for some reason, then I’d suggest to check whether the firewall/router isn’t blocking the connection. You could also try using a different browser to be 100% sure.

I checked both firewalls and they do not show the blocking of any attempts to access each other.

By trial-and-error I found the reason (or a workaround?). It seems to be a HTTPS vs HTTP problem. If HTTPS is turned off on the android node, its GUI can be reached.

The android node does not have access to the internet. Does HTTPS needs to be able to authenticate its certificates against some internet authority?

You’re allowing remote access to the GUI, so I think HTTPS is very much required (see

However, you should normally be able to access the GUI with HTTPS without any issues. The browser may give you a warning, but it can be skipped. For example, this is what you see when trying to access the GUI using Chromium.

Yes, I got a similar “unsave” message using Chrome. I proceeded to the “unsave” website and got the mentioned result.

Update: Strangely, even if I reactivate HTTPS, the GUI keeps accessible. :thinking:

Thank you for the assistance @tomasz86

1 Like

There seems to be an other problem. At the moment I can only access the console from within Syncthing in the android app. But neither locally within a browser (Chrome) on the android node, nor from the windows workstation.

It does not matter, if “HTTPS” is activated or not. No access with or without “HTTPS”.

On windows, I only get the login prompt, that reappears after a login attempt. On android, a white screen with “Not Authorized” appears.

PS. When restarting Syncthing on the android node, “HTTPS” is activated again.




To test, I set up Syncthing on a second android device and I can connect to its GUI without any problem.

The second device runns the same ST-version as the one, that I can not connect to.

Android version on the second device is 9.

Android version of the first device (auth. problem) is 11.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.