On openshift(Redhat), "copy owner from parent : lchown operation not permitted"

I am trying to sync between Ubuntu 18.04 LTS and Ubuntu 20.04.6 LTS, and my pod is running on a redhat openshift distribution, with kubernetes v1.25.14.

When trying to sync, i get - “copy owner from parent: lchown <file_path>.<file_name>.tmp operation not permitted”.

Furthermore, when trying to run lchown manually, the command doesn’t even exist in the container. The pod has permissions to create a folder on the pvc that is mounted.

I tried changing the original files to root both for owner and group, and i still get the same behaviour.

Thanks in advance!

It sounds like you enabled syncing ownership without setting up the elevated permissions required to do so: syncOwnership — Syncthing documentation. If the container is our build, setting PCAP=CAP_CHOWN,CAP_FOWNER=pe in the environment may help.

Hey thanks for responding, what will be the impact if i disable changing ownership ? Thanks.

Then ownership will not be synced.

That part is completely clear, but function-wise, the ownership’s impact on the performance of the sync, if we assume my file doesn’t need that specific ownership to be ran properly on my side after it was synced.

Will there be any impact besides the fact it wont sync the ownership ?

I’ve set the copyOwnership flag to be false when adding a folder, and in my usecase, the functionality seems to be intact, thanks for responding, the issue is closed from my point of view.