on external drive: "Failed to create folder marker: mkdir /media/user_me/2TB/_sss/_Planning/.stfolder: permission denied"

On my linux mint 19.3 system, the folders within my home directory sync well. No problem here.

However, most of my data is on another drive that is mounted through media. Thus, one of them is on /media/user_me/2TB/_sss/_Planning/

Whenever I add the folder, I get the errors

  • “Failed to create folder marker: mkdir /media/user_me/2TB/_sss/_Planning/.stfolder: permission denied”

  • Error on folder dpaf1-vgwuf: folder marker missing (this indicates potential data loss, search docs/forum to get information about how to proceed)

I tried so far:

  • set all permission open read, write, execute for owner, group and others. First for _Planning, then for the folders above it, and in the end for the whole of media. It doesnt help
  • I read something about some syncthing user and some sc-syncthing group. I cant find them: they are not in the /etc/group
  • run myself “mkdir /media/user_me/2TB/_sss/_Planning/.stfolder”. No problem, I create the .stfolder there. So I can do it, but the syncthing program can’t.(?!)

So I dont quite understand what is the identity of the syncthing program. It is not run as my user (“user_me”)? But as what then?

How can I give it the permissions it needs to create the .stfolder in a folder on a drive that has been mounted on the media of Linux Mint 19.3?

Syncthing on regular Linux runs as the user you start it as. If you start it as yourself and you have access to the directory in question you should be fine.

Thank you for the answer.

OK,that makes sense. So that confirms that it is correct I set the permissions for my user “user_me”.

However, I keep getting the error as above.

Sorry, but this is not really a syncthing question.

I suggest you make sure that syncthing runs as the user you expect via top or ps, and if it does really run as the user you expect, then perhaps look at ACLs or something like that that might interfere with permissions.

Also try it yourself in a terminal before starting syncthing from the same terminal. If access works for you, it should/will for syncthing as well.

I checked with top and ps, and the process syncthing does indeed run under my user.

From the same terminal I can create the folder, no problem. But syncthing can’t. It gives the error: “mlvm5-u56w2 open /media/user_me/D2TB/allo: permission denied”

I also tried renaming the drive (name starts no longer with a number) and make sure the names of the folders do not start with an underscore.

Did you try starting syncthing on the command line - no systemd, snap, whatever, just as the user that can create the dir run syncthing.

I start syncthing from the command line. I didnt try systemd yet. I installed the package through snap.

The problem occurs here:

[ACPUR] 19:25:39 INFO: Error while trying to start filesystem watcher for folder mlvm5-u56w2, trying again in 1min: open /media/slvst/D2TB/allo: permission denied

See below for the full log: https://pastebin.com/SwVN06zh

Also, I tried to run syncthing with sudo, and then it works! Then it can process the file on the external disk (/root/media/slvst/D2TB/allo/)

Snap uses sand boxing so the program can only access specific directories. I recommend the regular Debian package (apt.syncthing.net).



That worked! So the problem is the snap. Thanks you so much!

(The functionality of this program is a godsend for my workflow).

(And on a side-not: Good to know for the future that snap ports programs with reduced functionality)


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.