Not a Syncthing issue, but One Node is Hogging all the Internet, can't surf while Sync is running

One of my nodes will use all available bandwidth while syncing and I can’t work out how put it back to the way it was. It worked problem-free for months.

I’ve the appropriate ports open, port-forwarding etc. and Syncthing works perfectly but it just wants all the internet to itself.

It’s connected to a router that is identical to my own, so I’m confident that side of the equation is ok. Both machines are odroids, and working normally.

I’ve noticed that with UPnP disabled the situation improves slightly.

I’ve rebuilt the OS on the odroid and made a new Syncthing identity but still this problem persists.

I feel there’s something silly I’m missing either with the router or a Syncthing setting.

Has anyone solved a similar situation? Any tips?

Use rate limits.

Or do proper proper QoS on the router, to give packets with other protocols|from/to other devices a higher priority.

I tried them but it didn’t make much of a difference. I limited Syncthing to 30% of bandwidth capacity. I’ll try a more agressive setting when I’m near that node tomorrow. Cheers.

It bugs me that it’s the only one doing this, I can’t see a difference in the router or ST’s settings - but there must be one somewhere.

Thanks, I’ll give that a go tomorrow.

Just to follow up, I’ve worked around this by setting the upload limit quite low.

The download limit setting didn’t make much of a difference, but the upload limit improved matters immediately.

I’m still not sure while this node needed special attention while none of the rest of mine do, but it’s all good now anyway.

I’ll scrutinise its router another time.

Thanks for the tips!

1 Like

This may or may not be an appropriate solution for you, but you could look into something like Smart Queue Management on OpenWRT:

When I set that up, I found that I could completely max out my bandwidth and still surf easily. I could even successfully do latency-sensitive things like multi-player games. It does a good job at balancing between connections so that they all get a slice.

Oh, thanks!

I’ve to share some connectivity which prevents me from doing WRT to everyone, though I’d forgotten to try it a bit closer to home.


@iceberg What @lfam wrote is true for me as well. Running a Router with OpenWRT, DD-WRT or Tomato should offer you the possibility to do some quality QoS. For me it was easiest to give my devices (via their MAC address) a lower priority than the default. This way my Syncthing uploads basically max out the upstream, while other people can be gaming without packet loss and high ping times.

Edit: If you have a cheapass router, or one of the shit models some internet providers force you to use, you will probably have to use another one, because “advanced” features like QoS are often not available with those. The best option in this case would be to replace the router. If that’s not possible make sure the providers shit router is set to NOT work as a router, but as a modem. Otherwise you will have to setup every port forwarding twice.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.