Nord VPN ( Desktop Linux and Android phone)

When my Desktop(Linux) running syncthing has NordVPN turned ON, it can’t sync with my Android Phone ( GrapheneOs also using NordVPN, always on) at home (so same network / Wifi ) .

Do someone knows what need to be tweaked / changed ?

1 Like

Is this when using default settings on the phone or have any of the settings been tweaked? Please keep in mind that local discovery is currently broken on Android, so you may need to have global discovery and possibly relaying enabled if you want the devices to connect.

In other words, are all of these four enabled?

image

1 Like

Tks !! I will verify those settings and get back to the forum…

Yes they are exactly as you showed

You haven’t tweaked any of those on both sides, right? If that’s the case, then I’d guess it’s probably something related to the very VPN that makes it impossible for the two devices to connect…

1 Like

This is what I think too… Tks for your time

With NordVPN on, your desktop basically appears like it’s somewhere else in the world. NordVPN’s client also acts like a firewall. Have you tried telling NordVPN to whitelist Syncthing’s network port 22000?

nordvpn whitelist add port 22000

(I haven’t used NordVPN in quite some time, and don’t have it installed on my current systems, so I can’t guarantee it’ll work, but it’s normally the way to allow local SSH access while connected to NordVPN.)

1 Like

tks ! it’s now working…