Node is permanently 'Offline'


I have just setup a node and fired it up (CentOS 5.10 x86_64) . The GUI is working but the node is permanently listed as ‘Offline’. I have changed the dynamic node setting to the host’s IP address but that made no difference.

At the moment there is no other node visible to mine as I am waiting for some internal firewall changes to be implemented - would that be the issue or should my node show as ‘online’ anyway.


That’s probably the thing. Online/Offline there means whether your node has managed to talk to the global discovery server. In this case it hasn’t, which probably means that UDP to/from that server is blocked.

Thanks - I have now setup a second Syncthing instance on a different internal subnet and both are syncing OK although they both show themselves as ‘offline’. I have turned off dynamic discovery and entered their IP addresses directly.

I have seen the posts about the global discovery server and found the code - what’s needed to get it running (although in our case we can probably do without it).?


  • The prerequisites from the “Building Syncthing” (Go, etc)
  • Check out the source code into ~/src/
  • go build ./discover/cmd/discosrv
  • Run the resulting discosrv binary on some suitable machine and configure the clients to talk to it (in config.xml).

I have the same issue as OP… Tried on W7 64 bit and Ubuntu 12.04 32 bit (and unofficial Android app). All sync works so far in multiple directions via all 3 devices/nodes within LAN. However, Ubuntu GUI reports server offline (others report online). UFW firewall open (same problem if ufw disabled). W7 works as expected (i.e. online) in same LAN.

Given the OP issue was with CentOS, I wonder if there is an issue with using the executables on Linux? Or is there something I’m missing? ufw is the firewall on the Ubuntu computer.

~$ sudo ufw status verbose
Status: active
Logging: on (low)
Default: allow (incoming), allow (outgoing)
New profiles: skip

To                         Action      From
--                         ------      ----
22000/tcp                  ALLOW IN    Anywhere
21025/udp                  ALLOW IN    Anywhere
22000/tcp                  ALLOW IN    Anywhere (v6)
21025/udp                  ALLOW IN    Anywhere (v6)

iptables excerpt

Chain ufw-user-input (1 references)
target     prot opt source               destination         
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:22000
ACCEPT     udp  --  anywhere             anywhere             udp dpt:21025

Details: Syncthing v0.8.17 and v0.8.18 (v0.8.16 and v0.8.17 on Android). No manual IP used in settings (i.e. default asettings), ports open as per discourse forum sticky above.

Well, there’s no Linux issue as such because it works fine for me under Ubuntu. The online/offline indicator is based on being able to talk to the global discovery server, nothing else. You can run “STTRACE=discover syncthing” to get a bunch of debug output, which might yield some info about what’s happening - but in principle, either the packets aren’t getting out or the responses aren’t getting in.

Thanks for the reply. My output from STTRACE:

My errors:

19:06:08: Failed to create UPnP port mapping 19:06:08: Global discovery: stat /etc/resolv.conf: no such file or directory; no external announcements

The UPnP error doesn’t seem to trouble my W7 use. I presume it relates to resolv.conf. I use opendns on my router.

Any clues?

Right, sorry for missing this.

Global discovery: stat /etc/resolv.conf: no such file or directory; no external announcements

That means there is no DNS configuration on the box that syncthing can use, or it’s in an unexpected place. Without DNS, there will be no global discovery, hence the “Offline” marker in the GUI for global discovery.