Node disconnects after a second, invalid encrypted path

I have multiple devices running both MacOS and Linux (Debian/Buntu Family). MacOS FS is not Case Sensitive or Journaled. My Linux Devices (Raspberry PI) are setup as receive encrypted, and sync well enough until a certain point, at which they just connect, sync for a second, then disconnect, then wait a few seconds, then repeat. The error from the sending devices are basically:

2024-05-11 13:19:10 Lost primary connection to DEVICE at QUIC-SERVER-ADDRESS: handling index-update for FOLDER: invalid encrypted path: ".Trash" (0 remain)
2024-05-11 13:19:10 Connection to DEVICE at QUIC-SERVER-ADDRESS closed: handling index-update for FOLDER: invalid encrypted path: ".Trash"

I do not know where these files come from, or why it is always creating the file structure the folder i am syncing has on the encrypted side. (These unencrypted folders are also a problem) Since the devices are set to receive encrypted i also cannot add ignore patterns. I already have set a ignore pattern on the trusted devices but that didn’t help. Deleting the files manually doesn’t help either, they just get recreated. There is T (Trusted) and U1 and U2 (Untrusted) connected like this.

 / T \
U1 - U2

Okay i think i fixed it by ensuring all of them were up to date (one of the PIs was still on Fermium Flea, the repo version instead of the ppa), deleting all files in the Folders, and rebuilding the folder with POST /rest/system/reset — Syncthing documentation

This seemed to fix the unencrypted dir structure appearing in the encrypted folders. as for the .Trash, after adding ignore patterns to all of my connected devices, this didn’t happen either, however it might have been the same error where unencrypted data was mixing with encrypted, which was fixed by the command as linked above:

curl -X POST -H "X-API-Key: abc123" http://localhost:8384/rest/system/reset?folder=ab1c2-def3g

I think the main problem is that on iOS using 3rd Party Möbius Sync, (dont know if fixed everywhere else) the banner notification doesnt actually check whether you need to supply a password but just adds the folder sharing, which was then probably having problems with the outdated version and the inconsistent encrypted status of the folder (me experimenting with setups)

1 Like