No UPnP device detected

I did a fresh install of ST on two Windows PCs after screwing both of them up with ST trying to ignore various files. At that point, nothing connecting.

Now, after deleting the ST folder in AppData on both and restarting to see the default folder on both, I attempted to add the devices to each other. There’s still no connection. The final line in the log for each is the subject message.

Firewall on both enables both public and private.

Where else can I look for the block?

Did you add syncthing as an exception to the firewall?


Moot point, now.

I uninstalled everything and went to the folders and deleted the .stfolder files, too. Then started over from scratch and now it seems to be working. I truly don’t know what happened.

Well, I guess I wrote too soon. All the devices are disconnected again with “No UPnP device detected” as the last log entry after scanning again.

Edit: I’ve tried turning off Windows Firewall on the devices and they remain disconnected.

Is there something in this new version v0.11.21 that might be at issue?

(I’m grasping at straws, here…)

Yes. Try this again with v0.11.22.

Looks good so far after about 15 minutes.

Semi-related question: on one device, I run it with “Automatic Upgrades” de-selected. When I clicked the button to upgrade to the new .22 version, it returned an error saying that access was denied to creating syncthing.exe.old.

So I deleted the ST files in its directory and manually unzipped the new version there. It’s now running the new version, but in settings, there is no longer any checkbox to enable auto upgrades if I wanted to. Is there a fix for that?

Here’s what I see there. No option to set upgrade choice.

Strange. Is it the official build off github or off apt repos?

Yes, directly from GitHub. I was so happy to read that there was a connection issue with the previous version (and that it wasn’t due to my own setup), so as soon as read that here this morning I downloaded straightaway.

As I wrote, though, there was a problem with the installation regarding the syncthing.exe.old creation. The upgrade would not run.

So I deleted the files in the ST directory and installed the new version directly there in place of the old. It is running, all is connected, but you see that the upgrade option is missing.

I did nothing with the AppData directory when I deleted the program files and unzipped the new ones, so maybe there is some kind of mismatch going on between the two folders. I have this installed on 4 Win PCs, two on automatic upgrade, two manual. This problem only exists on one of the manual devices. The other one upgraded manually without issue.


This happens if the upgrade check towards Github fails when you load the GUI – i.e. if the upgrade server isn’t available, the option isn’t shown. Perhaps you have spotty connectivity or Github has rate limited you?

(This could probably be handled neater; the reason it does this, is that this is the same behavior that kicks in when the upgrading framework is disabled at compilation time…)

Well, here’s an update. For a completely unrelated issue, I had to restart the PC. Upon restart, I looked again on the browser page and the upgrade checkbox option is now there where it is expected to be.

So that’s that.