New folder permissions


I using Syncthing on Synology (Realtek RTD1296, armv8, syncthing-linux-arm64), binary taken from Reason for another repository: cpu not supported by default.

Everything works perfectly, but I found that folders, firstly created on another Windows machine, when migrating to Synology - are not using permission form parent folder, for example:

Parent folder permissions Admins: Full access Users: Read sc-syncthing: Full access

New folder permissions sc-syncthing: - Everything except change permission and folder deletion syncthing: Read Everyone: Read

How can I force Syncthing to use parent folder permissions when ST create new folder from another PC? I cannot set permissions for user “syncthing” on the root folder, only for “sc-syncthing” user.

Unix doesn’t do parent permissions like Windows, and Syncthing on Windows doesn’t send the permissions Syncthing on Linux would need. Your specific use case has been discussed though

Thank you for your answer, but I cannot find place, where to change umask, the only place whwre I see syncthing is usr/syno/etc/synoservice.d/pkgctl-syncthing.cfg

{“auto_start”:“no”,“init_job_map”:{“upstart”:[“pkgctl-syncthing”]},“is_package”: “yes”}

p.s. I am Windows user, my knoledge in *nix is only googling.

You need to set umask for the user that is running syncthing

Also, setting umask is a unix question that can be answered by google and is not specific to syncthing, especially when it comes to exotic os’es.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.