NAS (i486) - Error : Illegal instruction

Hi all,

I can’t say how impressed i am with Syncthing. I was looking for an alternative to get rid dropbox and BTsync and finally i found it.

I am trying to set up my environment and so far i managed to sync one NAS and one Win pc. My issue is that i am trying to set up my second NAS for disaster recovery backup ( as my experience with NAS devices is bad).

The hardware i have is an old Linksys NAS 200 which is an i486 device. I downloaded the 386 linux version (syncthing-linux-386-v0.10.0.tar.gz) and tried to run it on NAS without luck.

Hardware info: $ cat /proc/cpuinfo processor : 0 vendor_id : unknown cpu family : 4 model : 0 model name : 486 stepping : unknown fdiv_bug : no hlt_bug : no f00f_bug : no coma_bug : no fpu : no fpu_exception : no cpuid level : -1 wp : yes flags : bogomips : 49.76

When i try to run the binary i am getting the following error : $ ls -l sync* -rwxrwxrwx 1 root 0 8137744 Oct 8 14:05 syncthing $ ./syncthing Illegal instruction $

Any idea ?

Thx Alex

Please see Let me know if it helps.

Tried the version syncthing-linux-386-v0.10.0+6-g6e670a2.tar.gz but i am still getting the same error

$ ./syncthing Illegal instruction

How can i enable logging when i execute the binary ?

Some additional info about the hardware:

NAS200 has an RDC 3210 System On Chip. This basically emulates a headless PC running a 486SX processor at 133MHz

Did you try the static build (it’s not visible from the version output if that is what you’re running, unfortunately). That’s the minimum baseline we can build, excluding SSE instructions. It does however require hardware floating point, and you mention 486sx so maybe that’s an issue.

On the other hand, the 486sx is 23 years old now; it might be time to move on. :wink: