Missing checkbox for automatic update

Hi everyone,

I had a problem on my syncthing repos with the checkbox for the automatic update in the web ui. In my enviorment i have one master and 4 slave running syncthing. As I had taken a look today i was a bit confused, that three of the 5 syncthing installations had the version 0.10.27 and two hab 0.10.24. The first thing i was thinking about, was that i had forgotten to enable the automatic update on this two maschines. As I taked a look on the web ui I noticed, that ther isnt the checkbox for the automatic update on this two mashines. The other with the current version still have the checkbox. I had compare the config.xml but i couldn´t find a difference, so i decided to download the current version, delete the old one und start with the new version. The chekbox still not there, did anyone know what i have to do, to enable this checkbox in the web ui. I think it must be in the configuration files, because i have kept them.


If you got syncthing from your distro package manager, they usually disable upgrades.

Hi AudriusButkevicius,

i don´t use a package from my distro, i had download it direct from the original place at github. I have done the same procedure on all my maschines.

Strange. You should chrome debugger tools what does the /rest/upgrade api call returns. I expect we are hiding the checkbox because we somehow failed to contact github.

If your connection to github is file, the checkbox should reappear after the upgrade. You can also manually upgrade using syncthing -upgrade

Ok, now i know, what has happend. Your tip with manually upgrading has shown me a error about uknown authority for the github ca. This was done by an corporate firewall which handles the https trafic with an transperant proxy and that changes the https certificate to that of the firewall. I had downloaded the firewall ca und saved it under /etc/pki/ca-trust/source/anchors/ (CentOS) then I had updated the ca trust with update-ca-trust extract and now it works - the checkbox is there again =)

That’s working as intended then. :slight_smile:

Do we need an error log / console entry here?

I think we log an info level message when the automatic upgrade check fails. But we don’t do anything more intrusive as it could be something as simple as internet not being available.