Map locatie

Everything looks good in the right terminal window. Unless ss -n | grep :37391 in the left terminal was too soon (not enough time for Syncthing to finish its startup), there should have been visible output.

There is going to be a lot of lines, run this in the left terminal:

ss -n

ss -n This one is super long Does not fit the screen.

No problem. When you post a reply on the Syncthing forum, press [Ctrl] + [E] and paste the output from the ss -n command where it says “type or paste code here”.

Get the message that it doesn’t fit. Continue tomorrow. Get visitors Maybe TeamViewer better??

try team viewer then

Sure, sounds good. I usually use AnyDesk ( instead of TeamViewer because it’s a lot smaller program (used to use TeamViewer but it’s gotten a bit bloated over time).

Would it be an idea to delete syncthing on the Odroid and put it back on. Then I need to know the right way to delete, so that nothing is really left behind. It’s just an idea, otherwise it will all get complicated. Now I already have to start Syncthing manually on the Ubuntu PC. I prefer it to start right away as soon as the PC is turned on. Of course I also want this on the Odroid and any other PCs. Now I boot up the PC and nothing happens until I launch Syncthing.

Yes, it is a good idea to first undo/remove all installations of Syncthing on the ODROID before starting over. I think it was great that you tried different options because it offered a chance to see which method works best for your setup.

Ubuntu PC…

There is more than one way to auto-start Syncthing when the PC turns on because different users might need delayed start, or not starting on a laptop while on battery power, etc.

But if none of the above applies to you and you just want Syncthing to auto-start whenever your PC is turned on, here is the easiest method:

First, I am assuming that…

  • Syncthing was installed using the APT package from either Ubuntu or Syncthing and not Docker, VirtualBox, some other system.
  • You log onto your Ubuntu PC as “edwin” and not “root”.
  • Once logged on, you normally launch Syncthing with the command syncthing and not sudo syncthing.

If one or more of the above is incorrect, either correct it, or ignore the instructions below.

But if it is all correct, then run the following commands in a terminal window:

  1. loginctl enable-linger
  2. systemctl --user enable syncthing

Now you can reboot the PC and Syncthing will auto-start, or you can manually start it without rebooting like this:

  1. systemctl --user start syncthing

Step 1 is not absolutely necessary, but it allows Syncthing to continue running even if you log off the PC without shutting it down. Otherwise Syncthing will only run when you are logged on (a screen saver lock is still considered being logged on).

Step 2 tells Ubuntu, and other Linux distributions that use systemd, that you want to enable Syncthing to auto-start.

Step 3 starts Syncthing right away without needing to reboot.

Thank you for explaining. Have now removed syncthing with "sudo apt-get remove --auto-remove syncthing " Syncthing is now no longer on the Odroid. Now look up how to install syncthing on the Odroid. I see on various sites that you can install syncthing in various ways. Now the question what is the right way?

One more tip… the command loginctl user-status displays the current runtime status if you are curious if Syncthing or what other programs are set to auto-start.

That is a very good question… :grinning:

There really is no single “right” way to install Syncthing because different users have different needs, systems and setups.

On a Linux system, the easiest method to understand, install and maintain is using the host package manager. It cannot get much easier to install than a few clicks in a graphical package manager, sudo apt install syncthing or sudo dnf install syncthing in a terminal (the terminal method works everywhere, including on remote headless servers like your ODROID). This is one area where Linux users have it easier than macOS and Windows users because Linux systems have tightly integrated package management often with software catalogs containing tens of thousands of packages.


Besides cleaning out the DEB package, it is a good idea to also remove the Docker and other instances to avoid potential conflicts.

For extra assurances, I would also do a full filesystem search using the following command:

find / -iname "*syncthing*" -ls

Since you do not yet have a working Syncthing setup on your ODROID, consider removing anything that has “syncthing” in its name, including any configuration files.

Part 2…

After cleaning things up on your ODROID, since the version of Armbian you are currently using on your ODROID is very recent – “Armbian 22.08.8 Bullseye” (“Bullseye” is a recent version of Debian) according to your screenshots – you can either use the Syncthing package available in Armbian, or install the one directly from

Because the reason you are still running Ubuntu 18.04 LTS on your PC is fear of something breaking during an upgrade, the best option on your ODROID might be to stick with the Syncthing package from Armbian so that Syncthing will be upgraded along with other system packages.

If that is what you prefer, make sure that your earlier attempts did not add the APT repo from Check the contents of the APT repo directory with the following command (using the graphical file manager is also fine):

ls -l /etc/apt/sources.list.d/

If you see any files with “syncthing” in the name, delete them.

Next, verify that Syncthing is in Armbian’s software repository:

apt-cache show syncthing

For example, the output from the command above on my Ubuntu 22.04 LTS system:

gadget:~$ apt-cache show syncthing
Package: syncthing
Architecture: amd64
Version: 1.18.0~ds1-3
Built-Using: go-md2man-v2 (= 2.0.0+ds-5), golang-1.17 (= 1.17.3-1ubuntu1), golang-blackfriday-v2 (= 2.0.1-3), golang-github-alecthomas-kong (= 0.2.17-1), golang-github-audriusbutkevicius-pfilter (= 0.0.5-1), golang-github-audriusbutkevicius-recli (= 0.0.6-2), golang-github-azure-go-ntlmssp (= 0.0~git20200615.6637195-1), golang-github-beorn7-perks (= 1.0.1-1), golang-github-bkaradzic-go-lz4 (= 1.0.0-5), golang-github-calmh-xdr (= 2.0.1-7), golang-github-ccding-go-stun (= 0.1.3-1), golang-github-cespare-xxhash (= 2.1.1-2), golang-github-chmduquesne-rollinghash (= 4.0.0-2), golang-github-go-ldap-ldap (= 3.4.1-1), golang-github-gobwas-glob (= 0.2.3+git20180208.19c076c-2), golang-github-golang-snappy (= 0.0.2-2), golang-github-google-shlex (= 0.0~git20191202.e7afc7f-1), golang-github-greatroar-blobloom (= 0.7.1-1), golang-github-hashicorp-golang-lru (= 0.5.4-2), golang-github-jackpal-gateway (= 1.0.7-1), golang-github-jackpal-go-nat-pmp (= 1.0.2-2), golang-github-julienschmidt-httprouter (= 1.3.0-1), golang-github-kballard-go-shellquote (= 0.0~git20180428.95032a8-1), golang-github-lib-pq (= 1.5.2-1), golang-github-minio-sha256-simd (= 0.1.1-1), golang-github-miscreant-miscreant.go (= 0.0~git20200214.26d3763-3), golang-github-petermattis-goid (= 0.0~git20180202.b0b1615-2), golang-github-pkg-errors (= 0.9.1-2), golang-github-prometheus-client-golang (= 1.9.0-2), golang-github-prometheus-client-model (= 0.2.0-3), golang-github-prometheus-common (= 0.15.0-2ubuntu1), golang-github-prometheus-procfs (= 0.7.3-1), golang-github-rcrowley-go-metrics (= 0.0~git20180125.8732c61-3), golang-github-sasha-s-go-deadlock (= 0.3.1-1), golang-github-shirou-gopsutil (= 3.21.10-3), golang-github-shurcool-sanitized-anchor-name (= 1.0.0-2), golang-github-syncthing-notify (= 0.0~git20210616.c6b7342-1), golang-github-thejerf-suture (= 4.0.1-1), golang-github-urfave-cli (= 1.22.4-2ubuntu1), golang-github-vitrun-qart (= 0.1-5), golang-go.crypto (= 1:0.0~git20211202.5770296-1), golang-gogoprotobuf (= 1.3.2-1), golang-golang-x-net (= 1:0.0+git20211209.491a49a+dfsg-1), golang-golang-x-sys (= 0.0~git20211216.1d35b9e-1), golang-golang-x-text (= 0.3.7-1), golang-golang-x-time (= 0.0+git20200630.3af7569-1), golang-goleveldb (= 0.0~git20200815.5c35d60-1), golang-gopkg-asn1-ber.v1 (= 1.5.1-1), golang-goprotobuf (= 1.3.4-2), golang-protobuf-extensions (= 1.0.1-1), golang-siphash-dev (= 1.0.0-2)
Priority: extra
Section: universe/devel
Origin: Ubuntu
Maintainer: Ubuntu Developers <>
Original-Maintainer: Debian Go Packaging Team <>
Installed-Size: 18173
Depends: libc6 (>= 2.34), init-system-helpers (>= 1.52)
Filename: pool/universe/s/syncthing/syncthing_1.18.0~ds1-3_amd64.deb
Size: 6905554
MD5sum: 88ecb8444bfa9598116b2ab2beb95663
SHA1: c5a7a28ef2a39e20116241a19247de6c7e53bd8c
SHA256: f4a02da512fcf91832d153f986179b196c8eb23383663e06315da9d1ba10c191
SHA512: 7fb04f945643f755a5c86ca60421eccd567ebd39a4f86170158884fd7876a1e14a8ae33705a4b2dac9ef5e9d2637817e6b2b32cd0b9e2b461a9651c1a4465e26
Description-en: decentralized file synchronization
 Syncthing is an application that lets you synchronize your files across
 multiple devices. This means the creation, modification or deletion of files
 on one machine will automatically be replicated to your other devices.
 Syncthing does not upload your data to the cloud but exchanges your data
 across your machines as soon as they are online at the same time.
 This package contains the main binary: syncthing.
Description-md5: 1a4918fe5ed39dee33ebb3642be28ec0


Note the line that says “Origin: Ubuntu”. It indicates that the DEB package shown was built and provided by Ubuntu.

And here is the output from dnf info syncthing on my Fedora Linux system:

[root@files ~]# dnf info syncthing
Last metadata expiration check: 1:59:02 ago on Fri 25 Nov 2022 11:28:31 AM CST.
Installed Packages
Name         : syncthing
Version      : 1.22.0
Release      : 1.fc37
Architecture : x86_64
Size         : 24 M
Source       : syncthing-1.22.0-1.fc37.src.rpm
Repository   : @System
From repo    : updates
Summary      : Continuous File Synchronization
URL          :
License      : MPLv2.0 and MIT and OFL and CC-BY and BSD and ASL 2.0 and ISC
Description  : Syncthing replaces other file synchronization services with something
             : open, trustworthy and decentralized. Your data is your data alone and
             : you deserve to choose where it is stored, if it is shared with some
             : third party and how it's transmitted over the Internet. Using syncthing,
             : that control is returned to you.
             : This package contains the syncthing client binary and systemd services.

[root@files ~]# 

Once you have confirmed that all previous traces of Syncthing have been removed and that Armbian provides an official package, then install it via sudo apt install syncthing.

Armbian 22.08 uses systemd, so the same commands for enabling auto-start on your Ubuntu PC also work on your ODROID but I recommend launching from a terminal until you have a working Syncthing setup.

Launch Syncthing from a terminal on your ODROID and confirm that Syncthing is listening on port 8384. If it is, you are almost at the finish line. :wink:

oops, That last post is a bit complicated for me. With “find / -iname “syncthing” -ls” I do see some syncthing passing by. I’m afraid it’s not all gone yet. In the root of the Odroid I don’t see anything, but with the command “find / -iname “syncthing” -ls” I do. How will I do that. In docker there is also nothing about syncthing anymore, but it may be hidden somewhere. Your last post needs a good translation.

Let’s start with dissecting just the find command:

find / -iname "*syncthing*" -ls

What the command above does is ask find to…

  • Start at the root (/) of the system drive.
  • Search for any file or directory name in upper and/or lower case (-iname = “ignore case”) that contains the word “syncthing” – e.g., “Syncthing”, “SYNCTHING”, “SyncThing”, “syncthing.exe”, “syncthing.conf”, “.syncthing”, etc. would all match.
  • For each match that is found, list it with details (ls is similar to the usual ls shell command).

Here are a few common Docker commands:

  • List all containers: docker container list --all
  • List all images: docker image list --all
  • Remove a container: docker container rm containerID
  • Remove an image: docker image rm imageID

The “list” commands display the container ID and image ID for each item found.

When removing a container and/or image, replace the word “containerID” with the actual container ID listed, same for the word “imageID” for the remove command.

For example, if the container ID is “9fd891c62fbf”:

docker container rm 9fd891c62fbf

Likewise, if the image ID is “006d393a4e6a”:

docker image rm 006d393a4e6a

This is the reason why I think new Syncthing users should initially avoid installing via Docker unless already very familiar with how Docker works. Stacking on another software package that is also unfamiliar makes it appear as though Syncthing is difficult to install. It is like jumping directly to Calculus before grasping basic math first. :smirk:

This is what I see in root of the Odroid. With the Docker commands I don’t see any syncthing. This is good then. Only the data with command " find / -iname “syncthing” -ls "

With command " ls -l /etc/apt/sources.list.d/ " I see syncthing.

-rw-r–r-- 1 root root 113 Nov 17 17:17 syncthing.list

How can I remove it?

Definitely. This means there is less chances of conflicts.

Looking over the first few lines in the screenshot…

The items under /var/cache and /var/lib are temporary files managed by the APT system, so no need to worry about those. They will eventually get cleaned out.

The line below looks like a directory was set up to be synced by Syncthing.

Check the directory to see if you there is anything you would like to keep, but I am guessing that it is likely empty. It is also fine to leave it alone since it will not cause any conflicts (the /srv directory is normally used for “serving” data).

The file below is a template for ufw (Ubuntu’s “Uncomplicated Firewall” tool). It simplifies configuring the Linux firewall to allow remote network access to Syncthing. There is no harm in leaving it alone since you might want to use it later.

The command to list any firewall rules on your ODROID:

sudo ufw status numbered

(The “numbered” parameter above is optional. It adds a number column to the output which makes it easier to read and work with.)

If the output returned is “Status: inactive”, the Linux firewall is currently disabled.

The next line is one of APT’s configuration files. It most likely points to Syncthing’s official repository (if you had previously followed the instructions on the homepage, it would have created this file).

Finally, the line below means that you have an existing Syncthing configuration.

Since you have not successfully configured Syncthing on your ODROID yet, best to remove it for a fresh start:

rm -r /home/edwin/.config/syncthing

The file is owned by root, so the following command will remove it:

sudo rm /etc/apt/sources.list.d/syncthing.list

In case you are not already familiar with what each part of the command line above means:

  • sudo is short for “Super User DO”
  • rm is short for “ReMove”

Now to make sure Syncthing is gone and to clean up any temporary files, run the following commands:

sudo apt purge syncthing
sudo apt autoremove
sudo apt update
  • The first command purges any existing syncthing package from the system.
  • The second command removes any orphaned packages that are no longer required such as software libraries that are not useful by themselves.
  • The third command updates the software catalog, including removing any references to the Syncthing repository that was removed from /etc/apt/sources.list.d/.

Hi, I hope it went well. There is so much information coming at me that I get a little lost. Because I always have to translate, the translation may not be displayed properly in Dutch.

I performed auto-start on the Ubuntu PC, but then no longer get to the syncthing http no. This one stopped again. Doesn’t work for me. What a hassle everyone. It is easier to use 2 USB sticks and occasionally make a 1 on 1 copy.

I understand that you mean well, but the explanation is sometimes too complicated for me.

2 PCs are now working with Syncthing. I haven’t done much with it yet because we’re just working on the Odroid.

Installed syncthing again, but get exactly the same as before. Nothing.

This won’t work on the Odroid.

Enough done for today.

Been working on this all afternoon.

To help with the translation, I have been formatting my posts in smaller paragraphs. Any commands that should be run are always in a separate pre-formatted text box. I also use Google Translate to see how might look to you (even though I do not speak/read Dutch).

We can return to setting up auto-start on your Ubuntu PC later. Best to focus on one thing at a time to avoid confusion (and frustration).

I was really hoping that you would run the commands shown above to clean things up, and then wait to reinstall Syncthing so that we could do it together step by step.

From personal experience training users, it is very easy to get lost when picking up bits and pieces of steps from a variety of places. Adding a language barrier makes things even more difficult.

I followed the steps to remove Syncthing exactly as indicated. Then I reinstalled Syncthing. Now we have been working on getting this program on the Odroid for quite a long time. In my opinion, and I’m almost certain that this won’t work to get syncthing on the Odroid. I’ve tried several programs to get on the Odroid, but some you really can’t get installed on it. It’s all well intentioned of you to send the info, but it’s better to stop. 2 PCs are working now. Maybe I’ll look further for another Sync program that I can get on the Odroid. There may be a program in Dutch. That’s a lot easier for me. Thank you.