MacOs Auto start on login via launchd not working

Hi Guys

Great app - works so well between my pi out in observatory and my mac in the nice warm house, save so much trouble I cannot thank you enough!

But! I rebooted the mac today and noticed my syncthing icon was gone, sure enough I cannot hit the UI in the browser and of course I did not notice there were instructions for setting up to run as a service when I log in. So I followed the instructions at:

https://docs.syncthing.net/users/autostart.html#macos

Twice. I made sure to run these commands as myself, not root - I am an admin on this mac.

Also tried the homebrew route. No dice. I have checked and double checked the instructions, the directory is there with the .app file in it, the plist file has been edited correctly, when I run the command:

launchctl load ~/Library/LaunchAgents/syncthing.plist

There is no error reported, the logs and error logs are just empty files, and if I try and load the service again it is reported as already running. I can stop it and no error, start it again, no error but the UI is gone (nothing responds on that port) and the app is basically not running.

If I run the binary from the location referred to then the icon pops up in the mac taskbar and all is good.

I also checked out this great script someone wrote and it seems to work, it just does the same thing as when I follow the instructions - i.e. runs a service that seems to do nothing.

What could I be missing? I’m running 1.9.0-1, I did notice there was an upgrade for me today which I installed. I did not try and do this with anny prior version.

Cheers Iain

The instructions you mention are for “core” Syncthing which is a command line program that doesn’t have a dock icon. You’re running Syncthing-macOS which is a Mac wrapper. You can auto start that like any other Mac app.

Excellent, thanks for your prompt reply Jakob.

Is it worth mentioning that in the docs somewhere? Like most users (I suppose) I expected the app to start up on restart and was drawn to those instructions when looking for a solution.

Just my 2 pennerth.

Cheers Iain