Mac OSX 12.3.1: `bind: can't assign requested address`

Hi

I had Syncthing running quite while for a long time, lately, I get the following error on my Mac OSX 12.3.1

[YZT3X] 09:23:35 WARNING: Starting API/GUI: listen tcp 127.0.0.1:8384: bind: can't assign requested address

I know this has been asked already and yes, I did check that nothing is blocking this port.

lsof -i :8384
āžœ  Syncthing

I even tried

nc -l 8384

and that worked fine.

I also checked that there are no instances of Syncthing running.

If I reconfigure the ip address in config.xml to my local ip (192.168.x.x) then it starts up.

Something seems to be preventing it from binding the port on localhost.

Note that I had tried to change to other ports such as 8385, 8386 and that did not help either.

Any guidance would be appreciated.

Seems like a firewall issue? Iā€™d google that error message in a generic osx context.

I turned off the firewall. Same error. I think my problem is that it looks as if my loopback device appears to run in ipv6 only.

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
	options=1203<RXCSUM,TXCSUM,TXSTATUS,SW_TIMESTAMP>
	inet6 ::1 prefixlen 128
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
	nd6 options=201<PERFORMNUD,DAD>

on my other mac lo0 shows up for 127.0.0.1

This was actually the problem I have no idea why my lo0 interface was no longer available at 127.0.0.1 (funny that nc -l 8384 still worked). But after doing

ifconfig lo0 alias 127.0.0.1

Everything worked again!