Mac FS Watcher

I just recently setup syncthing again after using a different product for while and when I previously had syncthing setup on my Mac I was using syncthing-inotify to monitor changes (which was working great). As I’ve been working through getting thing configured I see inotify has bee depreciated and the fs watcher setting added directly to syncthing.

I currently have 2 devices setup (1 linux box and 1 Mac). On my linux box the fs watcher is working great and picking up the changes right away, however on my MacBookPro, no matter how long I wait the change is not detected (delay was set at the default 10 seconds).

Is there something special that is needed on the Mac or is it not fully supported at this time? Any help would be great…I searched and didn’t find anything that specifically answered the question…Thanks!

If it fails to start, it should print a message in the log.

Did you enable it in the advanced settings? Are you using 32 bit builds or an old operating system?

Thanks for the reply. The log shows the filesystem watcher is started for the folder, and the delay is set to 10 seconds (the normal Rescan Interval is set to 86400 at the moment). I’m currently running Mac OS 10.13.3 and the 64 bit v0.14.44-rc.3

It should work in that case. Perhaps you should run with STTRACE=watchaggregator,scanner env var (or logger facilities) and check the logs for clues as you modify the files.

1 Like

So I was finally able to test it out further and when I run st with STTRACE=watchaggregator,scanner I do see the see the filesystem watcher starting…

[E6ZEK] 2018/01/31 08:07:27.894000 folder.go:142: INFO: Started filesystem watcher for folder "TestFolder" (ne6yx-uy4yg)
[E6ZEK] 2018/01/31 08:07:37.894585 aggregator.go:291: DEBUG: aggregator/"TestFolder" (ne6yx-uy4yg): No tracked events, waiting for new event.

however after adding a new file to that folder there are no new events in the log related to the change. After waiting about 10 minutes I hit the Rescan button in the GUI and the changes were picked up right away.

@imsodin ?

That points at the backend not working in your case, while it is on our mac build servers. Unfortunately I don’t know any simple way to debug this. @SenorLoco Do you have are can you set a Go dev environment up? Otherwise I will create some kind of test binary for further debug (don’t have time right now though).

I think it must have been a one off issue on my ended. I blew up my entire syncthing installation and started from scratch and it appear that things are working how they should be on my Mac. Thanks again for the assistance.

1 Like

It might not have worked if for example folder marker was missing.

Weird, but I am not going to complain :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.