Local Discovery does not work on Windows10

SyncThing works well between 2 Android phones with enabled “NAT Traversal” and “Local Discovery”. but my Windows10 PC (not virtual) does not receive changes unless i enable “Relaying” and “Global Discovery”.

_ all devices running on the same WiFi (set as Private Network on W10 PC) _ all devices indicate full signal strength _ all have the same “GUI Listen Address” _ all 3 devices are set to Send and Receive basically all have the same settings.

Sometimes wifi and wired networks are in different subnets, in which case local discovery is unlikely to work. Check their IP addresses.

It could also be windows firewall, even if it’s disabled you might have to add the rules for it to permit multicasts/broadcasts.

1 Like

i just noticed that the 2 Android phones have a “GUI Authentication User” and “GUI Authentication Password” even though i never set them up. both fields are empty on Windows10.

add the rules for it to permit multicasts/broadcasts

how do i do that?

The ports required are described in the docs, and I am sure there are plenty of guides on the internet for adding firewall rules on Windows. Suggest you try disabling the firewall first.

1 Like

you are correct. i turned off FireWall and everything started working. i know how to add rules to Firewall but now i will seek “the docs where the required ports are described”.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.