Linux: synching is too verbose in the terminal


#1

Hello everybody,

When I started Synching in the terminal emulator, the terminal is constantly populated wit messages like these:

[DQPIN] 15:02:55 INFO: Connected to already connected device HPOEOTT-MJAVDVM-D2DKAHW-DWLBI4O-EKYGYBV-PJKOQDI-FFLGSH3-V6BIEQU (existing: 10.0.2.15:50304-158.69.220.91:22067/relay-client new: 10.0.2.15:46250-192.99.71.152:22067/relay-server) [DQPIN] 15:03:08 INFO: Connected to already connected device HPOEOTT-MJAVDVM-D2DKAHW-DWLBI4O-EKYGYBV-PJKOQDI-FFLGSH3-V6BIEQU (existing: 10.0.2.15:50304-158.69.220.91:22067/relay-client new: 10.0.2.15:46258-192.99.71.152:22067/relay-server)

Is there a way to avoid those messages?

I am a Manjaro user, and I installed the program using Pacman.

Thanks for your help, A.


#2

Hi A As Linux users, we do not have the -no-console switch which would do exactly what want. I have tried starting syncthing > /dev/null The terminal remains open, but all of the output is sent to the null device rather than the terminal window.

I hope this is of help.

Michael


#3

Instead of running syncthing in a terminal why not use the systemd service? sudo systemctl start syncthing@yourusername and sudo systemctl stop syncthing@yourusername or to have it automatically start you can enable the service with sudo systemctl enable syncthing@yourusername