Linux ppc64

When trying to run the 1.18.3 binary pp64 on Void Linux ppc64 the terminal returns: Unpermitted instruction. I have checked that the binary can be executed as a program.

I have tried running it as root as well. I am running it from ~/Downloads, should that make any difference?

What kind of CPU do you have? Did a previous version work?

I haven’t been using this computer for several years, last thing I ran on it was Ubuntu MATE 16.04 ppc64, and it ran fine then…

I don’t think that CPU’s been supported since Go 1.9 which is several years back. You might be able to run a similarly old Syncthing.

Ah I see… Yeah when I look in voids ppc repository I can see that both GO and syncthing is unavailable for ppc64. Too bad, haha.

When I think about it now I do seem to recall that the Powermac G5 started getting unsupported by syncthing around the time Debian dropped support for it, but that syncthing was forcing me to update and that that updated version didn’t run either, think it might even have been the same error message.

I presume now that running a version of syncthing which is old enough to support the G5 wouldn’t be a great idea, right?

It would probably mostly work, with the limitations and bugs of the time of course. But that’s the way with old boxes.

Good starting points might be v0.14.36 (last built with Go 1.8), v0.14.44 (last built with Go 1.9) and v0.14.49 (last built with Go 1.10), v1.0.1 (last built with Go 1.11). Officially support was dropped with Go 1.9, but sometimes it keeps working for a bit longer with luck and depending on what features of the compiler we actually tickle. You’ll have to set insecureAllowOldTLSVersions or whatever it’s called in modern versions to communicate with them.

And, obviously, if whatever version from the dark ages turns out to not actually be compatible with the latest hotness due to whatever feature drift, you’re on your own. :slight_smile:

1 Like

Haha, yeah I figured as much :smile:

I’ll tinker around a bit and see. Worst case scenario I’ll just use the G5 as a DVD player :rofl: