Linux Capabilities not working for NFS mounted volumes

I have 2 Ubuntu servers running Syncthing version 1.23, each having NFS version 3 mounted lustre file systems where users’ home directories are. We need to sync all the users’ home directories between these two servers. The issue is that even with capabilities set (CAP_CHOWN,CAP_FOWNER,CAP_DAC_OVERRIDE), Syncthing running as any user other than root encounters “permission denied” errors starting with the creation of the .stfolder and .stignore, preventing sync process from starting. When I tried syncing folders on local drive (i.e. not NFS mounts) Syncthing worked fine with non-root, unpriviledged user.

Has anyone run into such an issue before and is there a solution? Thanks for any help/suggestions you can offer!

I don’t think Linux capabilities are communicated over NFS or supported in any way by an NFS server.

I think you must activate ACL on the NFS share. E.g. redhat acl

Thanks for the suggestions. The ACL idea and link led me to another option I hope to investigate soon. It is from this link NFS Share with root for anonuid / anongid - Server Fault. The idea is to use NFS v4 and ID mapping between NFS client and server. Hopefully, it will work and I can post my results here.

thanks again!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.