Limited upload speed?


I am new to Syncthing. My problem is, that the Web GUI shows a max upload of 1.25 Mbytes. I tried uploading different file sizes and I always have a max of 1.25 Mbytes. My normal upload is 11 Mbytes.

I am syncing to an other PC over the Internet.

I am running Win 7 64bit

Things I have checked:

  1. No upload/download limits set
  2. CPU load = about 1%
  3. RAM usage = 60MB
  4. My provider upload rate = 11 Mbytes
  5. Download rate of the receaving PC = 10 Mbytes

I am just wondering why I cant get a higher upload, even though my pc is almost at IDLE.

Greedings, xXMICXx

What are the download/upload limits, CPU load, RAM usage, on the PC you’re syncing to?

  • Download = 10 MByte
  • Upload = 5 MByte
  • RAM usage (of syncthing) = 84 MB
  • CPU load (of syncthing) = 0,5%

Is one of the sides still scanning?

Scanning period is set to 200 seconds on both PCs. It is just saying “synchronising” in the GUI on both PCs.

Maybe you’re connected thorugh a relay? But I don’t actually know how you can see that…

The address section on a device shows either “address” or “relayed via”

Yea, it says “Relayed via” and the IP. Do I need to port forwart on the receaving PC?

On either side.

I opened the ports TCP 22000 and UDP 21027 and now the PCs are instantly connected. The “Ralayed via” changed to “Address” BUT now it is even slower. 720KiB/s :frowning:

Edit: Going to sleep now. It´s 00:10 here in Austria. Thanks for the fast replies. We gonna fix that :wink:

So it depends on the data set. The best way to benchmark it is to send one large file, many small files will be slow due to the overhead.

Also, what is the latency like between the machines?

I also tried it with a single file (about 12GB) but there is no difference. I am not home till monday but the ping must be about 50ms. I read a lot on the forum and the strange is, that most people say that syncthing is using to much system power. But for me, it was never over 5% CPU load an 150MB RAM.

Did you check the usage on both sides?

Just to make sure there is no confusion here, you mention your line rates as “10 MBytes” (per second, presumably) which is 80 Mbps and “11 MBytes” which is 88 Mbps. Your max transfer rate is 1.25 MBytes/s which equals 10 Mbps. Are you sure you are not in fact on a 10 Mbps connection?

I checked the usage on both PCs.

  • During Sync:
  • Sending PC: max. 5% CPU Load and 170 Mbyte RAM use.
  • Receaving PC: max 1% CPU Load and 80 Mbytes RAM use.

My line rates are 100 Mbit/s (up- and download) wich are about 10 Mbytes in practical use.

I have some Servers rented and I never had any problem transfering data. I am uploading to servers with about 11 Mbyte/s.

1 Like

Then I don’t know what the problem is…

You can try increasing the number of pullers in advanced folder config to something like 300, and see if that makes any difference. Also, make sure bandwidth limits are not enabled on either side.

Ok, will try that on Monday. Thanks.

I set the pullers to 300 and it made absolutely no difference. I will try to sync to an other PC on weekend. Maybe it works then.

Back again. I tired to sync to an other PC. Same thing. I just get around 1.5 Mbytes/s and my PC is at 1% usage… I opened all ports, connected directly, inceased pullers and pusher. But nothing helped.

I also tried using an other program and there was no problem sending the data. Got about 11 Mbytes/s. But I really want to securely transmit data. And syncthing is the best way.