Large Files not Synching

Have you tried visiting the URL people keep giving you? That contains your answers with instructions how to upgrade?

I’m now not sure my posts are coming across correctly.

Did I not say 3 times before I had followed the link and followed the instructions? In fact, the initial install we did on both servers was done from that link, and I stated that as well.

Did I not post the screenshots of the last apt commands showing my version 1.4.0 was already the latest version?

Did I not also say, 3 times again, the other server is updated to a slightly different version?

Did I not ask how to upgrade the 0.14.43-ds1 client (unless 1.4.0 and 0.14.43-ds1 are the same client, which is still not clear to me)?

Did I ask if 1.4.0 was the latest version, as from the web site, it appears to be?

The answer is “Yes” to all of those questions. I am not being derisive. I am not creating controversy. I have been nothing but attacked for simply asking a question. I have been nothing but accused of not following instructions that I clearly proved I followed.

I do believe from reading other posts and other web sites this can be made to work. I clearly understand I don’t know this tool and am perfectly clear I may have done something wrong. But this constant position you folks have that because the results of what you tell me to do is not working, that I am somehow causing controversy.

Good luck with the future of Syncthing. It looks like a good tool and I didn’t land on it lightly. I did my homework before deciding upon it.

At this point, though, I have no choice just to give up on this for now. There are other tools and methods available.

1 Like

Hi Joe:

(I’m not an official here - just a bystander…) Firstly - welcome to the forum. I’m sorry you feel besmirched by the advice you’ve received; my personal experience is that this is one of the friendliest, most informative, most helpful, most enthusiastic open source communities out there. Perhaps you’ve just encountered people on a bad day (considering what’s going on in the world, that may well be the case). Perhaps you wound peoples’ backs up by misquoting version numbers, or suggesting you had been admonished in your second post of this thread (I can’t see anything that reads that way…)

So let’s move to productive ways forward, shall we?

Looks like you’ve got two servers - DellR710and DellR710-1.

From what you’ve posted, it looks like you’ve upgraded DellR710-1 but not DellR710 yet.

If you believe you have upgraded DellR710 already, please post the apt commands you’re running there (as you did for DellR710-1).

1 Like

I agree with my previous speaker. It is one of the best forums I know. And when I read the thread, I see no major excitement. I know it myself, the people here want to do a very professional job and have to deal with many problems every day, so standing can also be a bit stressful.

We have to be careful, to deal with facts and values without errors, this applies generally to everyone, that is what we mean. We only write here and do not talk to each other. We know that, you write a message on WhatsApp and the other person understands it differently, as you mean it. When we talk to each other, we have many more indicators that we say things in such a way that they are understood correctly, we are missing here.

Maybe you can take up the suggestion and send a few screenshots, logs etc. available, that sometimes says more than words.

It looks to me like the core issue here is version confusion, so maybe the following will make things a bit clearer:

  • Syncthing v1.4.0 is the most recent version, at the time of writing.

If you installed syncthing with the Debian/Ubuntu package manager apt (or apt-get), there are two mirrors which both host different syncthing versions.

  1. The official Ubuntu repository, which is present by default. You say you’re running Ubuntu 18.04. This Ubuntu version distributes syncthing 0.14.43+ds1-6. This is a custom build, made by the Ubuntu packagers, and is based on syncthing v0.14.43. Note the leading zero here, which is important.
  2. An inofficial repository, hosted by the syncthing project, that always contains the latest version (again, that is 1.4.0). This repository is available under apt.syncthing.net.

Version v0.14.43 is over two years old and is incompatible with newer versions (see the announcement below). Since then, syncthing has made the “1.0” milestone, which is why newer versions have a leading “1”, not a “0”.

It looks like you have one device running v1.4.0 and one device v0.14.43. The latter device has installed the version from the Ubuntu repository, which is why it’s so outdated. You need to add the syncthing repository to that device, then upgrade it normally (apt update & apt upgrade). You have already done this on the other device, but apparently not on both.

1 Like