KDE Plasma wifi hotspot - devices don't connect

Hi, my laptop and android phone connect fine in my home wifi. But at the moment i am travelling and the wifi i am using here does not allow connections between devices (avm fritz.box guest wifi). My laptop is running debian bullseye with kde plasma. I have enabled the kde wifi hotspot and connected the phone to it. The devices work fine, e.g. kde connect on the phone can be used as a remote control for the laptop. But the problem is, that syncthing does not see the other device. Neither can the laptop see the phone nor vice versa.

Where could i check what is wrong? I did not see any obvious issues in the log.

I suspect that since there is no internet connection, this could cause the issue (e.g. global discovery server unavailable). The two devices are alone in the hotspot wifi. But i am a bit lost, where to check next.

Thanks in advance.

1 Like

Local discovery is currently broken in newer Android versions, so global discovery is required in order to make the phone connect. If there’s no Internet, I think you’ll have to hard-code the IP addresses in order to make the two devices find each other and establish a connection.

1 Like

Thanks Tomasz. I’ve configured the address of the laptop as “tcp://10.41.0.1:22000” on the android phone and disabled the global discovery and it then connected finde. If I enter the ip address of the phone on the laptop I can see an error “connection refused”, but this might be caused by syncthing not running as a service on the phone. Best regards, Torch

Just in case, I’d suggest to keep the global discovery enabled and set the address to dynamic, tcp://10.41.0.1:22000, as this will allow Syncthing to find and connect to other devices also when not using the hotspot (and you’ve mentioned your home WiFi above).

1 Like