Just working on one document, one PC - get 4 sync-conflicts?


#1

Writting on a new Word-doc on one of my devises. It took two hours - When finish clossing down word - I can see in the folder that I got one “normal” word-file and four “sync-conflict-sisters” like this

  • name_of_the_file.doc
  • name_of_the_file.sync-conflict-[date]-[time1>.doc
  • name_of_the_file.sync-conflict-[date]-[time2>.doc
  • name_of_the_file.sync-conflict-[date]-[time3>.doc
  • name_of_the_file.sync-conflict-[date]-[time4>.doc

how can it be done? I have only been working on the same PC / device. I’ve never tried that before.


(Simon) #2

The name of sync conflicts also contains the device ID (first part of), so you can check where the conflicts are coming from.


(Audrius Butkevicius) #3

You probably have the file open in multiple computers and the auto-save causes this.


#4

No as I tried to explain - Open a new word document - Wrote in two hours on same device/PC (NO Multipke computers) - saved from time to time and finely close the document) Then there were “one “normal” word-file and four “sync-conflict-sisters”


#5

Yes I can see which device it is

Its the device I was sitting doing the writing in the word Document


#6

I was trying doing a .txt file - the same thing is happening - It creates a lot of .sync-conflict files

By the way I am using the new version 1.0.0 Win 64


(Audrius Butkevicius) #7

So you create a file on A and without doing anything on A, you start getting conflicts created by A?

What are the other devices involved, are they NAS’es, mobiles, what type of filesystems they are on, etc?


#8

As Simon told in #2 the file name tells me that it is A (the file creating device) that creates the conflict-files So will the Remote Device then have any influence? But to answer your question - there have been one “remote device” turned on while working on the document - Its a Raspberry PI with Linux/Raspbian


#9

But it looks like it have something to do with the other device - I Paused the folder on the other device - and that helps


(Audrius Butkevicius) #10

I suspect the other device has a filesystem with some time drift or poor filesystem that looses time precision/changes files as they are written.


#11

It sounds very plausible. it is a rather old 8GB USB pen encrypted with Veracrypt

Is it a better USB the only solution or can I do something else?


(Audrius Butkevicius) #12

Try not using veracrypt, I suspect it fiddles with the files/timestamps which causes this.


#13

Well maybe a little old USB-drive - Verycrypt - Raspberry isn’t a good combination - But verycrypt works fine with Syncthing and Raspberry for all my other synced folders. But they are also working direct on a 64 GB SD-Card, not the USB-pen


(system) closed #14

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.