Is it possible that syncthing may have reverted a file back to an earlier version?

Server 1: Syncthing v0.13.0 Windows (64bit) Server 2: Syncthing v0.13.0 Windows (32bit)

A file a user worked on and updated in the early AM was reverted back to the original version. He noticed this later in the day and re-worked on the file around 4:30pm. It is worth noting that in the early AM, Syncthing was also crashing a lot (panic attacks), and I renamed the old index to .old so syncthing would create a new one.

Looked into Windows logs to see how this could have happened and noticed this:

User saved the file at 8:01 am. At 9:05 am, syncthing wrote to the file. At 4:27pm, user worked on and saved the file again. No activity from syncthing after this save.

I can provide the actual logs if necessary. Has this kind of behavior been observed? Is re-creating the index a bad idea in some cases?

If you nuke the index, while the data is not in sync, you might end up with old version. That’s more or less expected.


Ok, I guess that makes sense. Is there any recommended away with dealing with these panic attacks that don’t involve nuking the index? I have tried just restarting syncthing but it usually has a panic attack again after a short amount of time.

Rsync the files by hand from a source that is not panicing before blowing away the index.


Ok, thanks for clearing that up.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.