Is 1.3.3 slower on downloads?

Just putting this out there as i’m not calling it a bug. But i’ve noticed a job thats now plodding along where it used to be 15Mbps, now it’s a lot less

image

I did a speed test at the sending end and thats 20Mb down. It’s set up as a direct connection, not via relays.

On the sending side you need upstream, downstream matters on the receiving end.

If network bandwith isn’t maxed out, it may be other stuff that can’t keep up - for example, syncthing creates temp files and hashes data. If the system is not fast enough this slows down progress. A common slowdown factor is “lots of small files”.

This is how it looks for me. I personally would say it’s the same as usual, altough I haven’t looked much.

syncthing_stats

Sorry, I meant uploading, as in down to me. I have 70 coming in. Wrong wording. However I went to another office and did a test file of 320Mb. Again, this is a send only site and got this…

image

This is a fiber site of 70/20 and I would be expecting higher transfers. I have my setup to come directly to me and not via any relays.

You can look at the changelog, I don’t think the release had anything that could affect this.

If you are not connecting directly and using relays, it could be just down to the relay choice.

Also, you can validate your theory by downgrading and seeing if it makes a difference.

I wish there was a way to turn off upgrades full stop, but took it back to an earlier version and before it decided to upgrade I got this…

image

then after the upgrade went back to the slower speed.

As mentioned, I don’t use relays, I get the remote sites to point directly to my server.

I will see how it goes, and if any other users get the same, maybe they can mention it here.

You can turn off upgrades by opening the GUI, go to Actions -> Settings -> General -> Automatic upgrades. Another way is to set an enviroment variable (STNOUPGRADE, see the docs).

What versions are you comparing?

I found an old exe 1.3.2. rc1 in a backup so tried that.

I’ve done further testing taking both end back to 1.2.0 rc.1 and I still get a slow connection. I have restarted both routers and get the same slow speed. So I don’t know why it’s dropped. I don’t therefore feel it’s a bug in the current release (not that I said it was in the first place), but it did seem coincidental.

There’s a lot of reason why Syncthing might not be maxing out the network bandwidth (disk io, cpu). There’s lots of information out there in threads people asking the same thing (“why is Syncthing bandwidth lower than what a speed test reports?”).