"insufficient space on disk for database" macOS v1.27.3 and v1.27.4-rc.1

Getting this message since yesterday on all folders. Running v1.27.3, tried v1.27.4-rc.1 but it has the same issue. The amount of freespace on my main drive where the database is stored shouldn’t be the problem. (350GB free of 1TB)

insufficient space on disk for database (/Users/<USERNAME>/Library/Application Support/Syncthing/index-v0.14.0.db): current 1.55 % < required 2 %

What does df ~/Library/Application\ Support/Syncthing report?

In any case, you seem to have changed the threshold since the default is 1%. Change it back, and you should be fine, even according to the apparently erroneous calculation.

This returns:

Filesystem   512-blocks       Used Available Capacity iused     ifree %iused  Mounted on
/dev/disk2s1 1953595632 1900697080  26183792    99% 3827038 130918960    3%   /System/Volumes/Data

Seems like 2% minimum should be no issue.

I wasn’t aware you can change the threshold for the database. Found it in the settings and changed it to 1%. Sync is now resuming without errors! Thanks!

So just to be clear, the numbers in the Syncthing warning seem correct, the disk is approximately 99% full (26183792 available blocks out of 1953595632 ~= 1.3% free).


Sorry, I misread the data. I found the issue. Finder is reporting ~350GB free, Disk Utility only 12GB. Looking into this at the moment seems it has to do with purgeable files and snapshots.

1 Like

Yeah, macOS gets more and more opaque as time marches on. See Disk reader - menubar widget shows incorrect value after some time · Issue #1624 · exelban/stats · GitHub for a somewhat similar issue I ran into. APFS is more or less a black box filesystem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.