Installing Syncthing on Synology DS716+II

Hello everyone.

I have the following problem:

I’m unable to install Syncthing on a second DS716+II for some reason.

I’ve done it before like 2 weeks ago on another DS716+II, using the spk from synocommunity repository.

But now, the spk just won’t show up on the second one, no matter what I do. I tried deleting and adding the repository and disabling and enabling betas again, but no luck.

Both of them have the latest DSM version.

Tried the regular Linux/Arm packages but those won’t work because of the file format. Tried changing to .spk but that won’t work either. Guess those are only useable with the CLI?

Is the spk discontinued or something? I’m really not that good with Synology products and really don’t want to compile the source myself or use the CLI unless there’s absolutely no other way, because I feel that I’m just gonna mess it up.

Is there any other place where you can download it?

Thanks in advance!

We wouldn’t know, as it is not from us.

The linux version of syncthing is no package, just a compressed file. You just need to download the file, uncompress it and launch the syncthing binary. For your NAS the linux x64 would be the best option.

I installed Syncthing manually on a Synology for testing a while back: How to install Syncthing (arm release) on Synology? - #2 by wweich

1 Like

Well, bad luck I guess. I was hoping I could avoid installing it this way, because I wanted the two NAS to be exactly the same. Don’t want to do the first one over again either.

I’ll try your method out later then and hope I can get it to work just as good as the first one with the spk installation.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.