Install Syncthing on Router with LEDE 17.01.4

I tried to install Syncthing on my router, but I got an error

./syncthing: line 1: syntax error: unexpected “(”

I tried searching for a solution but could not find it. The router is a TP-Link WDR3600 v1.2, with LEDE 17.01.4. The version of Syncthing I’m trying to install is 0.14.43.

Are you sure what you’ve downloaded is actually an executable? It looks like it might be a text file.

I download the syncthing-linux-mipsle-v0.14.43.tar.gz package and try to execute syncthing.

Just sayin’, ( doesn’t tend to appear at the beginning of binary files. Just have a look at it.

Might be the wrong mips version or something as well.

I tried the syncthing-linux-mips-v0.14.43.tar.gz package, ans when i execute syncthing i got a error “Illegal instruction”.

I tried the MIPS processor versions, and they did not work.

cat /proc/cpuinfo
>system type             : Atheros AR9344 rev 2
>machine                 : TP-LINK TL-WDR3600/4300/4310
>processor               : 0
>cpu model               : MIPS 74Kc V4.12
>BogoMIPS                : 278.93
>wait instruction        : yes
>microsecond timers      : yes
>tlb_entries             : 32
>extra interrupt vector  : yes
>hardware watchpoint     : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0ffb, 0x0ffb]
>isa                     : mips1 mips2 mips32r1 mips32r2
>ASEs implemented        : mips16 dsp dsp2
>shadow register sets    : 1
>kscratch registers      : 0
>package                 : 0
>core                    : 0
>VCED exceptions         : not available
>VCEI exceptions         : not available



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.