Initial scan getting stuck at 95%


(Bill) #1

Hi All, Hopefully someone can help me, I have had a look through the forum and although people have had a similar issue, I am struggling to resolve this one. It does its usual thing but then when it gets towards the end just hangs (See log attached) Also I have tried this on 2 machines with the same set of data and it is doing the same on that machine too. Any ideas? Any further info needed from me. Thanks in anticipation and also a big thankyou to all who created / support this software, we love it!! Regards, Bill Please see pics below: top one is when the scan has just got stuck… Middle is when Ram usage goes up and up until eventually the control panel crashe… Bottom one is where I have scrolled back up the log and found this, may be of use?:


(Jakob Borg) #2

You probably have a very large file or two. Scanning involves calculating the block checksums of files and keeping those in memory. For very large files this can require a lot of memory.


(Bill) #3

Hi Jakob, Thankyou for your prompt reply, yes you are correct one of the files is the start of a incremental backup of a large data/database server and is 3.23TB in size, I am just running a quick test and putting that file only into the syncthing share then restarting the scan to see if it passes. Other than getting more ram / more power in the hardware (which wouldnt be that easy) do you think my best bet is to get our macrium backup software to split the large datafile backups? Thanks again and I look forward to your reply. Bill


(Jakob Borg) #4

Splitting it up is probably a good idea, yes.


(Bill) #5

Hi Jakob, we have decided to just ignore the initial ‘full backup’ huge files and only use syncthing for the smaller incremental backups. This is perfect for our situation as the initial backups never get changed or modified. So I think this is possible using the .stignore method, but I am struggling to get it working. I have tried creating a .stignore file in the folder (using windows and notepad then renaming it to .stignore. and by default windows removes the trailing . ) but when I restart syncthing it still keeps scanning that initial huge file. Am I correct that if I get the .stignore method working, synthing shouldn’t even attempt to scan the large files? Cheers, Bill


(Audrius Butkevicius) #6

The docs explain how to use ignores.


(Bill) #7

Hi All, just thought I would say thanks as this has now fixed my issue. Using the Ignore Patterns button worked a treat, we manually transferred the huge files and this has enabled incrementals to be sync’d properly. Thanks again, Will


(system) #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.