Info Message "Connect to myself"

I get an INFO message on the server running syncthing: “Connected to myself at [ip address]:22000/tcp-client/TLS1.2-TLS_ECDHE-ECDSA_WITH_AES_256_GCM_SHA384 - should not happen.”

Any thoughts on why this is happening, is it a problem, and if so how to I fix it?

its the next post :slight_smile:

But read the whole, to understand the idea of it.

I read the thread, but I am not using port forwarding or global discovery. All of my workstations are pointed to the server at the 192.168.0.9:22000. The server is listening on tcp://0.0.0.0: 22000. We specifically don’t want to use any server outside our local network for security reasons.

Because the IP is hidden its not clear what address it connected to, if its not a local address then it was found via discovery which probably has UPnP setup.

Audrius, all of the computers are within the local network. We only have local discovery turned on, but UPnP is turned off.

All of the workstations have connected to the server and are syncing their folders to the server file structure.

How do I check to see that the address is hidden and is that a problem?

If that ip is external then somehow discovery is still happening. If not, them you just have misconfigured something.

The IP is internal. I do have Local Discovery enabled.

If I enter the IP address directly in the client workstation, do I still need discovery enabled?

On the workstation in Settings–>Connections–>Sync Protocol Listen Addresses, I have entered the server IP address: tcp://192.168.0.9:22000. Is this correct?

On the server in Settings–>Connections–>Sync Protocol Listen Addresses, I have entered tcp4://0.0.0.0:22000. Should this be blank or the actual LAN address of the server?

Forgive my questions as I am new to Syncthing and trying to pick up where a previous IT person left after they did the initial setup.

If you are hard-coding IPs everywhere you don’t need local discovery.

Whether the IPs are correct I don’t know, I don’t look after your network.

I will turn off local discovery. Do I still need the listening IP entry on the client and server machines? I am currently using tcp://0.0.0.0:22000.

Yes