Increased memory usage since 0.11.2

I’m experiencing increased memory consumption since upgrading to 0.11.2 and 0.11.3 both on windows 8.1 x64 and Linux Debian Jessie x64. Windows version uses 584Mb while it used only 72Mb with the same amount of syncing stuff, linux stats are 206 to 85. I had to return to 0.11. I hope developers can look into this.

On my Windows 8.1 x64 one 300GB file is being transfered, currently taking 9,3GB RAM and a full CPU load. Running for over 48 hours in a Gbit LAN. Does not sound normal either. Also tested with 0.11.2 and 0.11.3 .

@zombied You’re probably suffering from, assuming you have a system with quite a lot of RAM. That may need adjustment, or at least an override. (It also looks a bit wrong in at least one detail.)

@SyncDuck, no idea what’s going on there… That’s 15 Mbps or less? And absurd memory usage…

I’m having 8Gb of RAM on Windows and 2Gb on Linux. So you’re just saying it is normal since 0.11.2?

Windows system with 24GB RAM here.

And to sum it up: my windows index folder is about 286mb and total amount of syncing data is less than 200Gb.

Normal-ish at least, as for an 8 GB system we allow up to 2 × 128 MB of database cache, which accounts for half of the increase you see - the rest may be stuff happening or GC overhead. The database cache gives a quite significant performance improvement, but I can see how this may be surprising and unwanted under some circumstances, so allowing you to decide and tweak this for yourself would probably be a good thing.

The 24 Gig system would get a 2 × 48 MB cache (yeah, the calculation is a bit broken as I noted above) so that doesn’t explain whatever is going on over there.

Yeah, tweaking thing sounds reasonable. Should we wait for this option?

This’ll be in v0.11.4:

Thank you, I don’t have any further questions. :smile:

0.11.4 is out but no promised block cache size config found. :confused:

It’s not exposed in the ui as most of the advanced settings, but it’s there in the config file.

OK. Where one can find documentation then? I get I should add <databaseBlockCacheMiB>XXX</databaseBlockCacheMiB> to the config file?

You can read level db documentation. If you force a config save (by changing some setting), the setting should appear in the config by itself.

My gosh, could you at least provide the direct link to it? I don’t know how to use this whole github site. Like a blind cat here…

I am on my phone, I am sure you could know how to use google just as well as I do.

[quote=“AudriusButkevicius, post:16, topic:2690”]use google[/quote]Smart… Don’t you think I didn’t try it? :smile:

I am not convinced.

It’s me or there is nothing about syncthing there at all? Anyway I have already figured the setting by myself. Just wanted to see a little support from developers.


Use your desired value instead of 0 (zero being auto detect). The old default was 8 MiB. The new, as of 0.11.4, goes up to 64 MiB for machines with enough RAM. So probably you already have a more reasonable value without needing to tweak.

1 Like