incorrect device id (solved)

Hello there, and sorry for my poor english :sweat: First of all, thank you for Syncthing!!! It’s exactly what I was looking for!

After installing it on my Windows 10 PC and my android mobile phone, I can sync a folder in local network.:blush:

BUT, impossible to do it through the web… I tried to understand by reading other posts on this subject. But I am not a professional. Some terms sounds unknown to me.

It might be related to the globals servers, right? Anyway, by moving my mouse on the GUI’s “discovery field”, I can see

"global@ security: incorrect device id

global@ security: incorrect device id

global@ security: incorrect device id

global@ Post dial tcp: lookup getaddrinfow: No such host is known."

(same for server 2 and 3)

One more detail: I’m living in China… But the problem is the same using a VPN.

Could you help me please?:sob:

Someone or some thing is intercepting your connections and inserting themselves in the middle to inspect the traffic - a so called man in the middle attack. This may be expected in your environment…

:fearful: How do you think I can fix the problem? Is it the same with the VPN connection?

Sorry, I don’t know. The error actually means it does not recognize the HTTPS certificate of the global discovery server. It could be some local antivirus thing as well that attempts to inspect the connections, perhaps.

I’m assuming you haven’t changed the configuration for global discovery servers yourself, as a misconfiguration there could result in the same.

As the discovery protocol isn’t necessarily very sensitive information you can override it by replacing the default discovery server URL with, where the “insecure” part means to not verify the certificate. You may then get a similar issue for the actual sync connections, which is not possible to work around…

Thank you for your response. I’m using Kaspersky Internet Security, wich is configured to inspect even the https connexions through their certificat. I will try to remove the secure connexions control…


It worked!!!:smile: Thank you a lot for your valuable help!


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.