ignoreDelete advanced flag not working?


I have a two way sync setup: A -> B

A is Send Only

B is Receive Only

B has advanced option to ignoreDelete enabled

If I create a text file on A, it correctly syncs to B

Example: ON A: touch CREATED_ON_A.txt ON B: ls -la CREATED_ON_A.txt results in file exists

Now, I delete the file on A, it is still being deleted on B

ls -la CREATED_ON_A.txt ls: cannot access ‘CREATED_ON_A.txt’: No such file or directory

As far as i understand, this should not be happening, as per the examples in the doc.

Any help appreciated. It is important for me that A can remove files, which will be retained on B after that happened.

It should work. Perhaps the flag is ignored for receive only folders.

Receive only folders are send-receive folders, that just behave differently while scanning (sets a receive only local flag) - so it should work exactly the same. And the setting is an early abort during the syncing operation, local flags don’t come into that. So essentially it should work and no clue what’s going on. Logs with model debug facility on and configs may provide some clue.

Thanks for feedback. Will get logs out as soon as the initial sync has completed of files, as logs are very very busy

ok, so I tested same action on another (identical setup) folder. Worked as expected. The test file was not deleted.

I am going to remove the current folder I tested in, on both sides, and see what happens when I re-setup.

Might just solve the issue


So, I deleted both folders, on A and B Recreated, and linked.

I created file on A, it synced to B I deleted file on A, it deleted on B

In B I have logs:

2019-07-16 11:06:51 receiveonly/movies-main@0xc00b24eb00 ignore file deletion (config) CREATED_ON_A.txt

But, it was removed on B

My previous thought that it worked in the other folder, was incorrect. The same happens.

Not sure where to get config. The folder, on B, as config in advanced:

Where can I get any config files you may need?

I did not share all logs entries as non of the others seemed related, and thus just noise. The file is not mentioned again in log.

That screenshot is fine, it shown the relevant stuff (ID matches log and ignore delete is set).

Unfortunately the log doesn’t help, it’s just a sign of everything working as intended (it’s not being deleted) - however it is. You could share the full log, even if not directly related there is a minimal chance there is something noteworthy in there. Other than that the only idea I have is to run a tool like fatrace that logs all filesystem operations, thus we can find out when it is deleted and check the logs for what Syncthing is doing at that time.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.