Ignore Patterns


I have an issue with ignore patterns, after adding some patterns, we seem to be getting an issue with one of the files.

error while traversing /home/centos/.ssh permission denied

after removing the additional ignore patterns we added, it seems to be fine again.

Here is the set-up (first two are new):


As you can see, we are not syncing anything under the /wp-content/uploads folder apart from two sites.

We wonder if there is a syntax error somewhere?

Kind Regards, R

If you are only trying to sync those two folders, I suggest you point syncthing at them, instead of pointing much higher up (which seems to be a home directory of some sorts).

We are syncing everything in the home directory, it has multiple WP installations.

Sure. Some patterns cause the whole folder structure to be checked, for example


We can’t guarantee that there is nothing matching *.bar inside of Foo, so we still have to traverse it, hence why we end up trying to traverse .ssh which syncthing seems to be lacking permissions.

In general, the more sensible option in your case would be to setup a folder per wordpress installation.

1 Like

I wonder if there is a better solution here… For example, I’m trying to sync the entire contents of /home/user, however this user chooses to make certain files and folders private… Syncthing will try to traverse those, and show Error - even when ignorepattern is set up for specific contents only:


That’s not how it works sadly.

Exclusions cause everything to be scanned.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.