Ignore List does not work on Android

In Android, tried to enter .mp4 files into the ignore list of the camera folder so they are not syncronized but the settings are not saved. I tried it over the web interface but the entry is not saved. Is there any advice how to do it anyway?

Regards Richard

I made an .stignore textfile in the synced DCMI folder and put in that “mp4” but videos are still synced

How about *.mp4? You don’t want to exclude files that are called mp4, but everything that ends on .mp4

I have tryed out both ways but videos are still synced

You need to put it at the root of the folder syncthing is looking after, not at any arbitary place. Furthermore, syncthing needs to be able to read it, which I am not sure it is able to, given it can’t create it there in the first place.

I suggest you check the logs

The .stignore file is located in the DCMI folder. This is the folder where the .mp4 files should also be ignored. When I open the .stignore file in the web interface, the .mp4 entry is shown… Is there a way to chage the permisions?

Here is the log --------- beginning of main 10-19 22:47:01.880 5752 17168 I SyncthingNativeCode: [OECHD] 20:47:01 WARNING: Saving .stignore: chmod /storage/emulated/0/DCIM/.syncthing.tmp.948183615: operation not permitted

Since it’s trying to synchronize the file, it’s not treating it as the ignore file. What folder are you syncing exactly? You need to put .stignore next to .stfolder

I am syncing the DCMI Folder and the .stignore is in the same folder with .stfolder

I am using ignores on my android and it is working. I would try renaming the file to make sure there aren’t any spaces in the name etc.

ST doesn’t have permission to make changes to the file yet… I believe this is being worked on with the updated API in GO but for the time being you will have to create the file in an external text editor. Once the file exists and is named correctly it should be picked up on the next scan.

Changing ignores from the app is currently broken:

I have created the .stignore file manually in the camera folder and entered the value .mp4. It has not brought anything, videos are still synced. I have checked again and there are no spaces in file name

The pattern .mp4 matches itself, literally, and nothing else. You are probably looking for *.mp4. See also https://docs.syncthing.net/users/ignoring.html.

1 Like

Yes *.mp4 was the solution

This was suggested ages ago…

… and you said:

My mistake, I thought I should try this difference mp4 or .mp4 Now with the asterisk before it works, you have to manually paste it into the folder on the Phone In the camera folder no files are generated that are called mp4