I can sync on WIFI but not Mobile Data


I have been having difficulty connecting when my android (rooted Moto G 4G) is not connected to WIFI.

I can easily connect to websites using the browser but for some reason syncthing cannot load and if loaded on WIFI and I switch off wifi connection, when attempting to load Web GUi, it says cannot connect to

I am not an expert when it comes to networks etc, so I could be out of my depth here.

Can you help?

Thank you!

There is a setting in syncthing-android to only sync while you are connected to wifi. Is that setting turned off?


Thanks for getting back to me. I can conform that the “Sync only on WIFI” is turned off. I have also tried “Sync as Root” as my phone is rooted (I am running Cyanogen 12 on a Moto G 4G).

I am also having this problem. When you say wifi do you mean just your LAN?

Hello Dugger,

Glad to know I’m not alone (although sorry yours isn’t working)…Yes bang on…

Wish I could help you further but I am running stock Android 5.1.1 without root access so our situations are pretty different.

It’s pretty simple, one of the devices has to be available on the internet, as in, have the port exposed on the internet via upnp, port forwarding or not being behind a router etc. If that is not satisfied, it will not connect, at least until all devices are running syncthing 0.12

What happens when all devices are 0.12? Is the behavior somehow different?

If the devices use global discovery and you did not disable relays, they should be able to connect to each other, without exposing one of them to the internet (firewall, port forward).

I remember a posting, that the official relay server will be rate limited to 100KiB/s. If you want it faster, then you will have to change your tounter/firewall settings, so the phone can get a direct connection.

Thanks for the response. Where can I read more about how the global relays work? Can I set up my own relay that ia exposed to the Internet and keep all my nodes unexposed? It seems there might be a security advantage to this. Also, if I set my own relay, can can I remove the rate limit?


I RTFM, for others the link is here: http://docs.syncthing.net/users/relaying.html

Still have the question about the rate limiting. Can I serve the relay on port 80 for maximum compatibility with third party networks?

Not specifying a rate limit does not impose one. You can choose any port you want.


What browser are you using? What mobile carrier?

I had trouble following your language. It sounds like everything is working on Wifi, but not working on mobile carrier. Loopback is so it shouldn’t matter what your mobile carrier is doing for accessing the WebGUI, but maybe your phone has a firewall blocking that port?

I am running rooted CM12.1 on Verizon and have no trouble accessing WebGUI from either Android stock browser or Chrome. I need to accept the self signed cert to access the site of course.

Try rebooting phone. Also make sure you didn’t type 172 instead of 127 (easy if you use RFC1918 /16 network 172 for your internal IPs. Check the port, 8384.

I have the same Problem two Android Device cant sync over LTE (My Provider is Vodafone). In My Local Lan they sync without problems. And both are connected to 5 of 8 announce server.

My Phones are Galaxy S6 Stock Android 5.1.1 Syncthing V0.12 Android 0.7.4 Samsung GT-N5100 Android 4.4.2 Syncthing V0.12 Android 0.7.4

I hope someone can help.

You need either UPnP or port forwarding setup for them to connect. I think relays don’t yet work on Android due to DNS issues, but once that is resolved, you should be able to connect even without open ports via a relay (with a big speed penalty).

@Zillode @Nutomic Thanks! :+1:

I have the same problem, synthing is working great over wifi. However, my devices shoes “disconnected” when I am on moile data and it is not syncing. Any ideas?