I am not working syncthing since I installed android 12 on my Pixel 3a.

When I had android 11 it worked perfectly. I also had syncthing installed on win10 and it synced folders and files perfectly. Now that I have android 12 installed I can’t sync because the devices don’t see each other. How can I fix this?

Thanks in advance!!!

Have you disabled the “Global Discovery” option by any chance? Or is the network that both devices are on not connected to the internet?

Android introduced some restrictions in recent versions that broke the local LAN discovery mechanism for Syncthing. That could be a cause.

only had local discovery. Now I have tried adding global discovery as well and it doesn’t work either.

Please make sure your network in Windows 10 is set to “private” and not “public”, or otherwise it won’t allow any direct connections, meaning that Syncthing will only be able to connect through a relay. Also, just for testing, if you have disabled relays too, please try to re-enable them and see what happens. Lastly, if that doesn’t help and the devices still can’t connect, you can try to simply hard-code the IP addresses.

We will see, but the difference could make Android 12 only.