Howto install manually Syncthing in a NAS DNS-320 (with funplug 0.5)

I accomplished it with this procedure :

1°) Syncthing site :

  • Download the latest release Linux ARM (“syncthing-linux-arm-v0.11.19.tar.gz”)

2°) 7zip :

  • Extract the file “syncthing”

3°) Filezilla :

  • Copy the file “syncthing” to /ffp/bin

  • Modify the rights of the file “syncthing” to 755

4°) Putty :

  • Launch syncthing (“root@nas:/# syncthing”)

  • Wait a few minutes for initialization and stop syncthing (with CTRL + C)


5°) GUI of my localhost :



5°) Filezilla :

  • Create a new directory “/mnt/HD/HD_a2/Tmp”

  • Change the rights of “/Tmp” to 777

  • Edit the file “/ffp/home/root/.config/syncthing/config.xml” and modify this:

– folder id=“Tmp” path="/mnt/HD/HD_a2/Tmp" ro=“false” rescanIntervalS=“60” ignorePerms=“false” autoNormalize=“false”


– /folder

– device id=“YYYYYYYY-YYYYYYYY-YYYYYYYY-YYYYYYYY-YYYYYYYY-YYYYYYYY-YYYYYYYY-YYYYYYYY” name=“My_PC” compression=“metadata” introducer=“false”

– /device

6°) Putty :

  • Launch syncthing

7°) GUI of my localhost :

  • restart Syncthing

Ok it works, but I have still some problems :

  • Often I must restart Synthing on my localhost so that connection is made

  • To leave Putty makes stop Syncthing

  • Howto launch Syncting at startup, there is not option “-no-console” ?

  • it would be there perhaps possible to simplify this procedure ?

I suggest you read the manual of the device you are using to learn how to auto-start syncthing (as it’s different depending on the operating system, usually you could just start it from /etc/rc.local) To keep syncthing running when you disconnect you can add & disown at the end of the command to send it to the background.

With this system make a script ffp/start/

But it don’t lauch because no option “no-console”, I think

command : syncthing -no-browser & disown

response : -sh: disown: not found

Use bash as the shell instead of sh. -no-console is only for windows, to hide the console window.

I am a newbie with Linux … Many thanks, it works fine !

Now I want autostart Syncthing, I have make in /ffp/start/ a script

  • (!/ffp/bin/sh)

  • (PROVIDE: syncthing)


  • name=“syncthing -no-browser”

  • command="/ffp/bin/$name"

  • run_rc_command “$1”

Howto adapt it with bash and @ disown ?

I have no clue, it’s your device, read the forums, I don’t think you need disown for the startup script.

I have found a solution with this /ffp/start/


#PROVIDE: syncthing


. /ffp/etc/ffp.subr





run_rc_command "$1"

With a copy of the Syncthing database in /ffp/var/

Syncthing launches correctly, but then I cannot be any more connected with Putty or Filezilla (refused connection), and the other process (Mediatomb) don’t launch at startup !

Well this script (as far as I understand as I have no clue about funplug) is supposed to be executed by the startup system, and not by you, hence why it takes over the console. See if it works after a reboot, as the init system should deal with that.

Yes it works after a reboot, but after this the others process don’t launch correctly, and I cannot connect to my nas with Filezilla or Putty.

If I launch this script manually as root (sh start), no problem)

It would seem that syncthing block the suite of startup

As I said, you should google around for instructions how to set this up on your system, as it’s outside of the scope of syncthing.

Ok I understand that it must be a problem of fun_plug and not of syncthing. But I do not understand why other startup scripts (eg. Mediatomb) return the hand after execution, while that of syncthing does not make it.

By waiting to find a means so that Syncthing returns the hand after his startup, I found the beginning of resolution: rename the script “” to “”, to make it carry out in last, what lets the others scripts put in the directory /ffp/start/

That’s not a good option.

You can write another script /var/run/ somewhere else which does:

/path/to/syncthing & diswon

and then change run_rc_command to point to that.

At the moment, my procedure is therefore the following:

Howto install manually Syncthing in a NAS DNS-320 (with funplug 0.5)

1 - Download the latest release Linux ARM (“syncthing-linux-arm-v0.11.19.tar.gz”), extract and copy the executable “syncthing” to /ffp/bin (with rights=755)

2 - Launch syncthing (“root@nas:/# syncthing”), wait a few minutes for initialization, and stop syncthing (with CTRL + C)

3 - Move the directory of the database Syncthing /ffp/home/root/.config/syncthing to /ffp/var/syncthing

4 - Edit the file /ffp/var/syncthing/config.xml and replace “” by “”

5 - Edit the file /ffp/etc/fun_plug.init, add this line at the end :

nohup syncthing -home=/ffp/var/syncthing &

6 - Reboot your NAS

7 - Configure Syncthing with the web_GUI in your browser with the adress [ip_of_your_nas]:8384

You can see the messages of the console in the file “ffp.log”


@AudriusButkevicius : thank you very much for everything !


Thank your for your tutorial, it works just fine.

  • D-Link DNS-320 (H/W Ver. : A1)
  • Firmware 2.05b08
  • fun_plug 0.7

But I encounter an issue, the transfer speed on LAN is very slow. It is below 10 Mbps. Meanwhile BitTorrent Sync can reach 40 Mbps and higher.

How can I improve transfer speed on my LAN?

Thanks in advance.

You most likely can’t - it’s a slow device, and syncthing does more work than bt sync.

1 Like

Thank you for answering.

Until I buy better hardware, I will use Syncthing with small files. :smiley:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.