How unstick invalid filename ?

I have some files on my Mac that show a forward slash in the filename. I don’t think it matters where they came from, but just in case, they came from an rsync download from a raspberry pi, e.g. .vnc/raspberrypi:1.log became .vnc/raspberrypi/1.log. I know that second forward slash looks like a directory separator, but it shows in the filename with finder or a command line “ls” list of files on the mac.

These mac slash filenames give my windows computer (syncthing’ed with the mac) fits - invalid file name pauses the syncthing puller.

So I deleted all the guilty files on the mac. But I’m still getting the same error messages on the windows machine. How do I get these files out of the syncthing memory, so that it stops trying to sync what no longer exists on either side?

This is a bug. It should only occur on 0.14.43-rc.1 - are you on that version? And if so, would you mind posting an issue on github?

Actually I don’t see how this could happen on 0.14.43-rc.1. I already forgot about how that part of my PR works, but it has a unit test (there probably should be a comment about it if even the author forgets within such a short time).

To stop myself guessing in the dark: What version are you on?

Also pulling is never paused, on the contrary, errors make it retry regularly. So everything else will keep working.

The actual error when I click on the web GUI 26 failed items says

... {many other filenames}
C:\Documents and Settings\User\My Documents\computer\Admin-Raspberry\home\pi\.vnc\  filename is invalid
... {more filenames}

Does that help? I’d like to fix this and thought that deleting files on both sides would fix it, but it did not. I just like to keep things clean in the logs when the same error for dozens of files keeps happening. I’d like to increase the “signal to noise” info in the logs.

I have mixed versions - an older v.38 on my Mac because newer version break the older OSes. I have v.42 on both Windows machines. I can’t upgrade the Mac to v.42 because syncthing immediately crashes with “illegal instruction”.

Big overall issue: How do I get syncthing to “forget” about files that I manually deleted and no longer exist on any sync computer?

It shows that the file is rejected due to the colon, which is correct on windows, but it shouldn’t happen if the file was deleted (see below).

That should happen automatically, if it isn’t, this is a bug. So I am trying to find out how it happens.

So to recap: “” once existed on mac on 0.14.38, but now is deleted and scanned. It still causes the filename is invalid problem on windows, which is on 0.14.42. As far as I can see this should not be possible (mind, I am not saying it isn’t happening). If the file is deleted and a scan happened on mac and the two device are connected, can you please enable model debug logging on windows (in the settings with Synctrayzor, in the Actions->log menu in the web UI) and make lines before the line containing “Pausing puller for” available - thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.