How to sync TWO folders on DS 418 with DS413j (no Drive)

Hi How to set up syncthing to sync two folders

Folder 1 on DS 418 to Folder 2 un DS413j (on DSM 6 with no drive server available in DSM6)

any ideas?

There are packages for Syncthing on the SynoCommunity repository. Have you installed them yet?

You might need to pick an older version (1.19.x) for the package on the DS413j and disable updates. Some people have reported issues with older DiskStations, so if you run into a problem, just post some details about what goes wrong here.

When you have mastered the initial installation, take a look at the documentation, especially the Getting Started Guide: Getting Started — Syncthing documentation

OK THX Installed it on both Synos

but now I have 2 Syncthing SERVERS on the Synos

Don’t I need a client on one Synology?

Syncthing is a P2P software and is no Client to Server solution. So install on each Synology the Syncthing package, give Syncthing the permissions to read and write and set your folders in the GUI. Thats it. Maybe read the documentation first.

1 Like

Great THX, so I should work BUT on DS414j it does not start I have this version installed also on DS418

when i open in DS418 = OK But on DS414j This How to fix?

I found a newer version here:

but have no Idea which file I should use for my Synos!

Can you Pls tel me what file to choose, and I will do a manual installation, maybe it’s fixed then?

What do you think?

The processor type of DS413j Marvell Kirkwood 88F6282 from group 88f628x with DDR3 512 MB. So it seems you need to add the SynoCommunity package information to the package center of your DSM 6 or alternate download directly[88f628x].spk

and try with that.

Syncthing itself no longer have a supported package.

THX installed manually Same - does not start! But it is still image

What’s about new version v1.21.0 here - as asked above.

Release v1.21.0 · syncthing/syncthing · GitHub

But have no Idea which file (1.21.0) I should use for my Synos!

Can anyone pls. Help to solve this?

A internally Update would be done automatically, if the package runs. Maybe run a Reboot after Installation to start the packkage.

Was there another package installed before? If yes, maybe a cleaning is needed before installing the Final Version.

You don’t need to worry about the v1.21.0 version. If v1.20.3 doesn’t start, the newer one will not work either. In fact, you probably need an older version that still works on your system.

This one should work:[88f628x].spk

However, if you just start it right after installation, Syncthing will try to upgrade itself to the most recent version automatically. That will fail again just like now.

So you must tell it to not start the service after installation. Then edit the options.conf file and add the --no-upgrade option. You need admin access to the terminal (best to connect via SSH) and then find it at this path:


Sorry, that is not really an easy way and requires many skills. The only less technical way I can think of is if you cut the connection to the Internet so it cannot upgrade right away. Then you should be able to access the GUI and disable updates there before reconnecting.

Thanks for your efforts, it’s a shame that syncthing isn’t kept backwards compatible

Resilio Sync worked great out of the box.

Yea, that’s pretty unfortunate. But it’s not really in our hands, but a decision from the Golang team at Google. I think it wouldn’t have been a big trouble to keep a fallback code-path to accommodate older operating systems, but it’s a fast-paced development model where not much care is taken for “old” systems.

Works now on your DS or not. If that package works basically you have v1.19.0 and the internally update to v1.22.0 should be no problem. Both versions are compatible, so even you run no update, it runs anyway.

By the way, Resilio’s update policy is subterranean, so nothing can go wrong that quickly, since there are hardly any updates.

Where do you see the Pros and Cons

Syncthing vs. Resilio Sync

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.