How to stop sharing a folder in a cluster?

I’m sharing a couple folders between two desktops and a laptop. All the devices are added to each other as introducers. I understand that this has to be done for the folders to sync in all directions between the devices.

Say I want to stop sharing one of the folders with the laptop. What is the correct way to do this in my scenario? I’ve tried unchecking the laptop from the folder in the WebUI on both desktops at the same time, but even that doesn’t always work. The WebUI on the laptop will ask if I want to accept the folder each time syncthing on the desktops restarts.

The way to accomplish this in btsync was to simply disconnect the folder from the laptop.

What am I doing wrong?

Introducer is a function, where the device will share all its known nodes with the ones where it is marked as introducer. So it is not needed for syncing and I don’t know the implications if every device is set as introducer on every device.

As your devices already know each other, the introducer setting is not necessary. If you would add another device, you could add one of your desktops as introducer, so the other desktop and the laptop would be added automatically to the new device.

I would try the following (with restarts when prompted):

  1. remove the introducer setting everywhere
  2. uncheck the laptop on the folder on both desktops
  3. uncheck both desktops in the folder on the laptop or remove the folder on the laptop

Uncheck the device under the folder; restart. There should be no step three - if there is, that’s a bug.

What wweich mentioned is correct… All the introducers have to unlist the device from the folder (at the same time) or the other introducer(s) puts the device back. With just 1 introducer it shouldn’t be a problem.

So if one of the introducers sees that another introducer unlist a device, so should he… if that would be the case i think it’s perfect

I’m having a very similar issue.

A friend and I started sharing a folder. He somehow set up the folder path wrong on his system, so that it was syncing his entire home directory. We both removed the folder from Syncthing and started over with a different folder ID, located in better paths. That works as it should.

Except I keep occasionally getting a notification about trying to share the old folder again. I don’t think he’s re-added the folder, so I don’t know why I keep getting this notice. Is this a bug, then, or are we doing something wrong?

It would be nice if instead of just “Accept” and “Later,” there were an option to “Reject” a request to sync a new folder.

Make sure syncthing was restarted after removing the folder. Reject makes no sense because it’s just a matter of misconfiguration at the other end, so the other end should unshare the folder to stop it from popping up.