How to run my own directory server

Hi guys! Good work so far!! Could you tell me how to setup my own directory server on my rpi?



I never tried it myself since I use the default discovery server, but just downloading the linux-arm build here and run it should work.

great thanks… may I ask another question: I do not know whats meant by in german: “Adresse(n) für das Synchronisierungsprotokoll” in english could be: “adresses for the syncprotokol”… I’m trying to get it run on my android (without wifi). I activated the global (official server) and opened the port 22000 on my router…

but it does not work… :frowning: what could I do?

I am running the discovery server and it works. As the Android implementation for GO currently cannot resolve DNS, you cannot use your own discovery with Android, unless you have a static IP.

In the addresses box, you can add one or multiple address(es) under which the device is reachable (e.g. your-dyndns-address:22000). But because of the not working DNS resolution, this won’t work on android, so you have to keep it at dynamic and keep the IP of the official discovery server in the settings. If you activated global discovery on both devices they should be able to connect (more precisely your Android should be able to connect to your home device and establish a bidirectional connection).

hi wweich… sorry… I was just trying to get file-sync running (not the directory server) on android… I wondered how to sync my android although I#m away from my home wifi… how could I set it up and whats the “address for protokol”? greetings!

OK, so: The address for protocol is the IP address and port on which your device will listen. Best to keep it at, which means that it will accept connection from every network card on port 22000 (e.g. would be for from this device only). The port forwarding for port 22000 on TCP in your router is already set, as you said. So if you leave every other setting to default, you should be able to connect and sync after adding the devices to each other.

tried it but it doesnt work for me :frowning: not even with one of my devices… the problem: I only can open the same port for one device (not for two)… local working like a charm - but globally not :frowning:

You can change the port on one of your devices, to say 23000 or something. Then forward that port to that device.

As for the discovery server these binaries on github should work nicely. The latest builds from source require a PostgreSQL server so require a little more work to set up. I’ll build a docker image for that some day.

thanks :smile:

tried it…including deactivating my fw and for testing purposes local search…

but it doesnt work :disappointed_relieved:

I’m running: device1: win7 x64 | v0.10.30 device2: win8.1 x64 | v0.10.30 device3 (outside wifi for testing): cyanogenmod 11 / android 4.4.4 v0.10.29 / 0.5.27

ay caramba! after a second reboot: device2 (laptop) connected with device1 (PC) device2 connected with device3 (Smartphone) but device1 (PC) didnt found device3… any ideas? :relaxed:

I would love to help the project, as I can:

  • If you need some german translation, drop me a line :smile:
  • I would write an article about Syncthing on (tool of the month) (is there a mediaset?)

In your screenshot you have only one port forward. Is that for device 2?. Is the port forward for device 1 (port 22000) still active?

yes… I now forwarded port 22222 to dev1 and 22000 to dev2 actually dev3 is getting the files from dev2, which is getting his files from dev1 :grin:

Just to be sure: You added each device on each device, so dev1 knows dev2+3, dev2 knows dev1+3 and dev 3 knows dev1+2; and you shared the folder on each device with the other two and accepted the shares on each device? Is just the syncing not working or is device 1 marked as disconnected on device 3?

Could you check the web interface on your Android. It could be that is is asking if you want to accept the share from dev1.

I successfully added all devices in “local mode” to each other. I then changed all devices from local to global an disconnected dev3 (Smartphone) from wifi… status quo: dev1 >< dev2 > OK dev1 >< dev3 > NOTOK dev2 >< dev3 > OK

sync is working as I said: but only because files are transfered like this: dev1 > dev2 > dev3. if dev2 is not running it wont sync…

after deleting dev3 on dev1 and adding it again, not even dev2 finds it :cold_sweat: