How to force upgrade

I have two laptops and one always on headless box all running Syncthing on Debian 8 with no Master. The two laptops have upgraded to v0.14.15, Linux (64 bit) but the-box is stuck on v0.14.13-dfsg1, Linux (64 bit). apt-get upgrade does nothing so I have tried: me@the-box:~$ sudo syncthing -upgrade 10:41:09 INFO: Default folder created and/or linked to new config 10:41:09 FATAL: Upgrade: upgrade unsupported me@the-box:~$ sudo syncthing -upgrade-to=""
10:45:18 FATAL: Upgrade: upgrade unsupported I have never tried direct commands to Syncthing before so I apologise if the answer is RTFM.

The build in upgrade doesn’t work for the PPA packages, as apt deals with the updates.

Just to be sure: did you realy just use apt-get upgrade or did you do a apt-get update before that?

If you can’t get it to work with apt, you could remove the PPA and use the version from github which will take care of upgrades by itself.

Another hack would be to locate the Syncthing binary and replace it with the github version. Auto upgrade probably still won’t work as the binary is placed where the syncthing user cannot write, but you would have the current version until you get upgrading through apt working again.

Just a note. v0.14.16 stopped my Debian 8 server talking to other Debian 8 servers. You might want to hold off upgrading the server.

Please see your own thread before scaring people off upgrading.

1 Like

apt-get update every time. I don’t normally have a problem with this, all three upgrade each time with apt-get, I will have a look at switching to the github method. To call my box under the stairs a sever is elevating its status rather, thanks for the heads up anyway, I am not easily scared. So I deduce from this that my update commands are rejected because I have not configured syncthing to update from github, is that a penny dropping? Thanks for the feedback.

syncthing -upgrade can be disabled on build. The syncthing team and most of the other “packagers” disable it for builds which will be installed and updated through the systems’ package manager. So mostly only manually “installed” Syncthing will be able to self update.

“…-dfsg” is a Debian build. It upgrades by apt-get like all other Debian things.

You can choose to run that, and get updates from Debian, or the releases and get updates from us (also via apt-get), or the Github binaries that update automatically.

As always comprehensive support. I am still puzzled as to why two out of my three computers have grabbed the update and not the third. Well that will give me something to do over Christmas… and a Happy Christmas to you all.


In case anyone is interested I have found the problem, below is the output from my box and my laptop both have the same Debian 8 O/S one without GUI but identical sources.list… the-box apt-cache policy syncthing syncthing: Installed: 0.14.13+dfsg1-1 Candidate: 0.14.13+dfsg1-1 Version table: *** 0.14.13+dfsg1-1 0 500 testing/main amd64 Packages 100 /var/lib/dpkg/status laptop apt-cache policy syncthing syncthing: Installed: 0.14.15 Candidate: 0.14.15 Version table: *** 0.14.15 0 500 syncthing/release amd64 Packages 100 /var/lib/dpkg/status 0.14.14 0 500 syncthing/release amd64 Packages 0.14.13+dfsg1-1 0 500 testing/main amd64 Packages 0.14.13 0 500 syncthing/release amd64 Packages 0.14.12 0 500 syncthing/release amd64 Packages

I will seek answers to this problem elsewhere.

One appears to have added as a source and is thus getting our release, the other one doesn’t and gets the Debian version.

1 Like

Yes, that is exactly the problem and is the residual fallout from reinstalling a system and wrongly believing that by reinstating the sources file all would be well. Anyway I hate to find incomplete threads when I am looking for answers and so for the benefit of any other hapless, forgetful aspiring administrators here is what to do…

  1. Add the release PGP keys: sudo curl -s | sudo apt-key add -
  2. Add the “release” channel to your APT sources: echo “deb syncthing release” | sudo tee /etc/apt/sources.list.d/syncthing.list The End and a Happy New Year
1 Like

(as documented here)


Update: upgraded to v0.14.17 and all my previous issues are resolved. :+1: This version is recommended.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.