How to force all Discourse notifications via e-mail?

I seem to have missed a lot of new interesting support topics here lately. Was always relying on getting a new e-mail whenever there is activity here on Discourse. But some things are not sent when the browser still has one (or dozens of) old tabs open.

What settings could I change to force e-mail for every possible notification?

You can’t do that. The support category is even excluded from the digest emails, whatever those are (I turned off email from discourse years ago so I’m not the best on the details here).

So what is the intended mode of operation for Discourse? I’m an e-mail centric user so whatever notifications I need to pull actively by visiting a website will most likely be missed. Plus I always have some browser tabs open in the background for stuff I expect to continue discussing. If that counts as “not away” in Discourse, then they are misinterpreting.

I think it’s a web forum? There is a mailing list mode where you can request to get every post as an individual email, and somehow attempt to parse incoming mail into forum posts; this has been disabled since roughly forever as we’re already with just the summary emails close to 10 thousand emails per month, which is the limit where sending email starts to get serious and costs money and whatnot. (And we’ve never attempted to set up incoming email.) (And I certainly don’t intend to, not that you asked for this.)

Guess I’ll have to get used to regularly going through the notifications list then. How do you use it? What’s your regular workflow with Discourse / open discussion tabs / etc.?

Note I’m only interested in the notifications, replying via e-mail would be too limiting and awkward I agree. But I understand the mail volume argument.

My usage pattern is to visit the forum and read unread stuff. I read everything, and do this fairly regularly during the day, so it’s typically just a couple of posts. Sometimes there’s a notification, then I click on it to see what it is. If something needs responding to, I do that. I don’t do long lived tabs, at all, though I know this is a popular thing. Discourse does background notifications though, sometimes I get those as well.

Thanks. I’ll see how I can adapt my workflow to it. Unfortunately I have many more things to do over the course of a day so that visiting regularly just won’t fit. However, reacting on e-mails if urgent or if I just happen to have a couple of minutes available was a pretty efficient pattern so far. Except for missing lots of stuff I now noticed :wink:

The options for “email me when someone replies to me etc” include “always”, does that not do what you want?

I also like to rely on e-mail notifications for everything. I’ve been using the following settings to achieve this, and they seem to have been working fine so far. Is your setup any different?

As far as I can see, I receive e-mails about new posts even when actively browsing the forum.

I’ve also added everything to the “Watched” category.

I think the relevant part is in the “Emails” settings, not under “Notifications”. But it doesn’t help apparently.

So you don’t get an email for this reply for example? (I’m assuming you’re also here and looking at it live, which should be the worst case for Discourse assuming you don’t want an email notification.)

Yes. I haven’t got a single e-mail from Discourse today.

I think both are related. I’ve got a feeling that you need to disable live notifications and other stuff (as in my screenshot) in order to receive e-mails instead.

I can’t disable Live Notifications. The button just won’t do anything.

What browser do you use? I’ve got all notifications disabled in Chromium, hence the button in the forum settings isn’t even active here.

I’m on Firefox and I do get notifications from it through the desktop.

… right, you’re not getting emails because Discourse has disabled emails to your account for a month because it was bouncing, since the end of December.

We don’t have log retention for email bounces (beyond the 5 days mailgun provides for free) so I don’t know what the bounces were. I’ve reset the bounce score now. Ideally, you would get a notification for this post, but I’m not sure if there’s some delay in the system.

Oh great. I did notice that the volume had reduced significantly since this year. No idea why it bounced…

Yeah, that bounced as well, and now I could see it. Your mailserver doesn’t like us (i.e., mailgun).

5.7.1 Service unavailable; client [] blocked using
5.7.1 please see

So, yeah. Email being email. :man_shrugging:

Mailgun is one of the least spammy providers I know of for sending thousands and thousands of emails per month, so I’m not sure what to improve here.

Firefox has built-in notification controls too, so you can try disabling notification access for the forum there, although seeing the @calmh’s posting above, the problem may be about something completely different, but I’m writing this just in case you still fail to receive e-mail notifications and would want experiment with other settings later.