How to debug "Out Of Sync" -problem properly?

One of receiving nodes is “Out of sync”. Now I have only one file in this state. No ignore patterns. Other is fully synced. I had more of those files but when I changed “Out of sync” -files names (only one character), then they synced.

I have tried to read debug logs from both sides (STTRACE=main,model,sync) with no luck.

  • What can I do to resolve this?
  • How do I find the reason file is not syncing?

There is a bug related to this, so you might not be able to fix it. You can run syncthing -reset-deltas on both sides and restart.

OK, -reset-deltas solved the issue! Thank you! I walked through several bugs on GitHub and searched forum, but was not sure if this is issue is still going.

Since it is not in the documentation:

Could you explain what -reset-deltas does?

Will the bug be fixed in the near future or do you think this is a long term workaround. Then I would implement it in my completion progress script.

It discards node remote state, which has to be retransferred on first connect, which brings the view of the world back in line.

If this is 5149 it so far hasn’t been reproducible with current master (@Tom?), so might be fixed by the new index batching there.

Btw: When do you expect the final version of 0.14.50 to come out? The date on top of the forum is obviously not up tp date.

unfortunately, 5149 has reappeared. All was well for 2 days, but today it’s back.

I will not be able to supply logging before 2nd half of next week :frowning:

1 Like

Workaround: you can create an (empty) file on sending device with the same name as “outofsync” file on destination device. Then rescan, wait for sync, delete file and rescan again.

That should bulldoze the file contenton the source I think, which might not be what you want.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.