How do you fix "Folder Marker Missing"? I tried removing and re-adding the folder, and still am stuck...

The device with the issue is running SyncTrayzor on Win11. The particular error is Error on folder "Videos" (#####-#####): folder marker missing (this indicates potential data loss, search docs/forum to get information about how to proceed).

What I tried was removing the folder from SyncThing, deleting the content on this specific device, and re-add from another device. But it just freaks out again. I don’t get it.

What’s weirder, when I try to re-add it, it doesn’t give me any opportunity to configure it. And while the app says the file location is in the place I expected (~/Videos), instead it’s making a new folder using the 10-digit ID code and dumping the data into that.

There’s supposed to be a directory/folder named .stfolder under each Syncthing folder (e.g., ~/Videos/.stfolder) that Syncthing checks for to see if it should be watching and syncing the contents – it’s a safety feature in Syncthing to prevent inadvertent deletion of data.

The marker folder is just an ordinary folder so simply recreate it and the error about it missing will go away.

(See the Syncthing FAQ for more details about the .stfolder marker folder.)

I don’t use SyncTrayzor so can’t really offer much input on this other than it sounds like it’s an issue on the SyncTrayzor side rather than on the Syncthing side.

Since SyncTrayzor talks to Syncthing’s API, at least temporarily, go directly to Syncthing’s web GUI at and configure things there instead until the other problems are resolved.

Why do you think it’s a SyncTrayzor problem? In this case, SyncTrayzor doesn’t talk to the API, it simply loads the Web GUI in its built-in browser.

@BurntVoxel Please post screenshots of the what you’re seeing on the screen. This should make things clearer. Please also be very careful with re-creating .stfolder manually, as doing so in an empty folder will make Syncthing think that you’ve deleted everything and then push those deletions to other devices as well.

.Net and C# aren’t my forte, but I am familiar with C++ and Java so it wasn’t too difficult to skim thru SyncTrayzor’s codebase, which is where I saw that it includes a “SyncthingApiClient” class.

At the moment I can’t think of a reason why a web browser would need a set of related classes and methods, but it sounds like it’d be useful for SyncTrayzor’s other features such as conflict alerts. (Perhaps it’s why SyncTrayzor’s API client does a HTTP GET request on “/rest/events”? There’s also a HTTP GET request on “/rest/system/config”).

Really, screenshots should help in this case. How do you actually “re-add it”? If it’s the usual dialog in the Web GUI / SyncTrayzor, then there is always a field where you can enter the folder path. The only case when you don’t even get to see that dialog is when you have Auto-accept enabled.

Or is there some feature in SyncTrayzor that allows you to add Syncthing folders without going through the Web GUI? Like an Explorer right-click thing?

Nevermind. I don’t understand what glitch led to this behavior, and I’m not sure what exactly I did to fix it, but I’m okay now. This is weird.


  • Typical home hub setup. My Android phone is everyone’s introducer, desktop PC dualboots windows (with SyncTrayzor) and Kubuntu (with just SyncThing, use the web view).
  • Everything’s working fine on other devices.
  • Trying to set up a Windows laptop with SyncTrayzor now.
  • Every folder seems just fine at first.
  • Something happened on the laptop and ~/videos/.stfolder got deleted, cue the error codes.
  • I handled it by deleting ~/videos/ from the laptop, then removed /Videos from SyncThing, then having the phone offer it again.
  • Still was getting "folder marker missing.
  • Second or third attempt at that, and I realize it’s not asking me where to put the folder, and instead just defaulting to the folder ID. I also tried restarting syncthing.
  • Sometime after I gave up and asked for help, I rebooted my machine and… now it works right. But again, it didn’t ask me where to put it, or even if I accept the offered folder.

Anyway I’m alright now even though I have no idea what happened. Sorry.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.