How do I turn off "watch for changes"?


#1

I have synctrayzor deployed on my small lan. A few months ago (april I think) a new feature of syncthing was promoted: “syncthing watch for changes”. I accepted that new feature on all workstations; one workstation seemeed to have difficulties accepting the new feature because it kept prompting to add the feature or not.

Anyways, I seem to have vastly more file conflicts now. I can’t be sure that the watch for changes feature is the reason but I would like to turn that off and see if things quiet down. Syncthing and synctrayzor have been great up until now, but the new daily file conflicts seem to be a risk. I don’t feel certain which file is best to keep; there shouldn’t be any conflict; so I just want to go back to how it was.

I cannot find a control point in synctrayzor for “watch for changes”. Can someone tell me how to turn that off? I would turn it off on all of the machines.

Thanks


(Antony Male) #2

Syncthing’s watcher is separate to SyncTrayzor’s watcher. SyncTrayzor’s has been around for a long time, but Syncthing’s is relatively new. SyncTrayzor disables its own watcher when it sees that you’ve enabled Syncthing’s watcher.

Disable Syncthing’s watcher in Folder -> Edit -> Advanced -> Watch for Changes.


(Audrius Butkevicius) #3

You are just closing your eyes and running away from the problem. You should fix the cause of the conflicts not look for workarounds that just induce data loss.


#4

OK, thanks. There is no system wide manner of turning off the syncthing watch for changes?

Also is this a known issue? I’m not even sure it is the reason I am having so many conflicts but it seems the place to start.


(Audrius Butkevicius) #5

No, there is no way to disable it across the board. I suggest you understand why the conflicts are happening, as to which two devices are stepping on each others toes instead of going for nuclear options.


(Simon) #6

Or in other terms: It would be beneficial to Syncthing (and any other OSS project in a similar situation) if you would have a closer look at those sync conflicts, things like what types of files get conflicted, when does it occur (and is it reproducible and/or can you provide logs from that time), do the files actually differ (they should), …


#7

The files that are now regularly appearing as file conflicts are really important to the work I do. It’s been disturbing to have to pick one file over another, not knowing why the file is being presented as a conflict, and which might be the correct one, if they are actually different.

What I am going to do it to turn off the watch for changes feature of synchthing and see if the issue is resolved. I will report back on that.

I don’t see a pattern to when the conficts arise other than that it is a folder that is shared between three pcs. I only work on the files in that folder on one pc at a time, never simultanteously.

It is a new bad behavior - I wish I had noted when it started misbehaving.


#8

Audrius there is nothig different about what I’m doing now than what I’ve been doing for a year. I work on the file in one location; now for whatever reason there are often file conflicts. It certainly has to be possible that a change in syncthing is causing the issue. I am specifically worried about data loss and the only thing I can think of to do about it besides #1 stop working or #2 remove synchthing is to disable the new Watch for Changes feature. I posted here asking for input on the issue, not to assert that I know what the issue is.

What exactly would you suggest I do to “fix the cause of the conflicts”? If I can’t edit a file in one location which is sync’d to two other locations, and never open it in more than one location…what is there to check?


(Audrius Butkevicius) #9

Check the recent changes log to understand where the changes are coming from.

Compare the files to see whats different.


#10

The file conflicts are still taking place even though I have the syncthing watch for changes feature turned off. Of the three machines that sync this folder only two of them are turned on.

I have looked in the log that is offered via the Actions menu item and it has the same content as the lower part of the synctrayzor main window. There is no log entry with any info about the file conflict, at least that I have found so far.

The file conflict resolution dialog currently states that there is a file conflict; the two timestamps are about 20 minutes apart. The file is being worked on on a single pc. The other pc does not have it open. The reported file size makes sense, the copy from the pc that does not have it open is slightly smaller.

But there is no reason that these files should be in conflict. The kind of action I’m taking with this edit is exactly what I normally do every day, and syncthing has not had any issues like this before a few months ago. Now these errors are common. Something has happened to syncthing that is causing these false file conflict reports. I don’t have a clue what that might be; syncthing and synctrayzor are complex and totally admirable as far as the magic they perform.

Please let me know what else I can contribute to shed light on this. Syncthing and synctrazor are really great; I’ve donated to synctrayzor and will donate to syncthing now, because both of these offerings are so useful and so well done.


#11

Another file conflict; the two versions are 4 seconds different from each other. Positively it was not open on the pc that I am not working on.

Bummer…this is now a regular part of working with files that are in the scope of syncthings settings. I sure hope there is a resolution soon.


(Jakob Borg) #12

You haven’t mentioned what kind of files these are of what the editing program is. That might give us a clue, even if the problem isn’t with that program as such.


(Simon) #13

Also as this seems to happen so often, you could enable model debug logging and look for lines mentioning the affected files (or just provide the entire log).


#14

I have not been able to find the model debug feature. After turning off the syncthing watch for changes things seem to be going better; might have seen the error one time immediately after the change. The files I’m editing are MS Access database files.


#15

But now I’ve have two incidences of the file conflict. Turning off syncthing watch for changes did not solve the problem.

There is always one file I’m working on; the other file is passive, no one is using it, 100% for sure, I am the only one who has access. Why does syncthing fail to understand that one file is untouched and the other is not? The normal time difference is usually just a few minutes; now I’m in the habit of always dismissing the remote file “change”. The only change it could possibly be from is from syncthing itself; it is updating the file periodically, but nothing else is.


(Audrius Butkevicius) #16

Try running the latest rc.


#17

I will try that; I’m not sure how I can run the latest syncthing rc with synctrayzor? What the synctrayzor about dialog presents is

synctrayzor 1.1.21 syncthing v0.14.49-rc.4

I have never dealt with syncthing directly, but rather also via synctrayzor.


(Audrius Butkevicius) #18

Seems like this is the latest rc.