High CPU and plugin unusable in Freenas

(Marco Sgrignuoli) #1

I use the Syncthing plugin v1.1.1 in Freenas 11.2-U3. After using the plugin for a few days and synced ~1 TB, the plugin started to behave weirdly and consume a high amount of CPU up to the point the even the FreeNAS web dashboard and any other jail became very slow and almost unresponsive. Looking for the problem online I found an article suggesting to turn off continuous scanning. Unfortunately, the web dashboard is so unresponsive that when I click “save” in the directory configuration, the change is not saved.

Thanks in advance for any suggestion!

(Audrius Butkevicius) #2

You should check the web ui to understand what it’s doing. 1TB on such a low powered device is probably too much. You can shut syncthing down, modify the config by hand and start it back up.

(Marco Sgrignuoli) #3

I believe Syncthing went into a bad state. I solved by unmounting the disk, removed all the directories, mounted the disk again, re added the directories making sure the continuous scanning was disabled. It’s been running for a few days and it looks fine.