help with permissions on Ubuntu

I know my way around the Mac command line but don’t have a huge amount of experience with Ubuntu.

When I create a small send-only folder on my Mac and send it to a read-only folder on the boot disk on my Ubuntu system, everything works.

However, I want to sync a large folder, and that involves syncing it to a folder on my larger secondary hard disk on my Ubuntu system. This keeps failing with permission errors.

I didn’t install the second hard disk but I have been able to glean it’s an xfs volume accessible at /dev/sdb1.

With ps -aux | grep plex it seems that the root user owns the plex processes that are automatically started by the command /snap/bin/syncthing executed by Startup Applications.

When Syncthing works on the small folder it creates on the boot disk, that folder’s owner is user, it’s group is user, and its permissions are drwxrwsr-x.

So I’ve tried sudo chmod 775 -R path/to/parent/of/target/on/second/disk and sudo chown user:user -R path/to/parent/of/target/on/second/disk.

To target the path on the second disk, I’m using /media/user/uuid... which was set up by the system’s previous owner.

I’m getting permission denied errors in the Ubuntu box. With the settings described here, in the Failed Items dialogue, it says syncing: creating directory: mkdir /path/to/child/inside/target/on/second/disk': permission denied.

I’ve tried a bunch of things, including sudo chmod 777 etc and sudo chown root:root etc. Each has changed the specific permissions error I have received – e.g. error creating .stfolder, error doing something else, etc – but none have many the errors go away.

Any advice? Thanks.