Help w/ Solaris - no logs, web GUI inaccessible via service

Hello everyone,

I have syncthing working moderately well on my Windows, Linux, and Android platforms

Tried to set it up on OmniOS file server, which is a great OS for AD file server, but a little tricky to get other things to work sometimes

Services are started with svcadm, kind of like systemctl, but svc files are quite a bit different and in xml format

Here’s my current syncthing.xml:

<?xml version="1.0"?>
<!DOCTYPE service_bundle SYSTEM "/usr/share/lib/xml/dtd/service_bundle.dtd.1">
<service_bundle type="manifest" name="syncthing">
<service name="site/syncthing" type="service" version="1">
<create_default_instance enabled="true"/>

<dependency name="network" grouping="require_all" restart_on="error" type="service">
<service_fmri value="svc:/milestone/network:default"/>

<dependency name="filesystem" grouping="require_all" restart_on="error" type="service">
 <service_fmri value="svc:/system/filesystem/local"/>

<method_credential user="synctg" group="users"/>

<exec_method type="method" name="start" exec="/opt/local/bin/syncthing" timeout_seconds="60">
                <envvar name="HOME" value="/srv/syncthing"/>
<envvar name="STNORESTART" value="1"/>
<exec_method type="method" name="stop" exec=":kill" timeout_seconds="60"/>

<property_group name="startd" type="framework">
<propval name="duration" type="astring" value="child"/>
<propval name="ignore_error" type="astring" value="core,signal"/>

<property_group name="application" type="application">

<stability value="Evolving"/>

<loctext xml:lang="C">

The two issues I’m having are:

  1. When started as a service with the above xml file using svcadm the web GUI is not accessible. If I invoke syncthing at the command prompt as the synctg user, web GUI works just fine.

  2. I can’t locate any log files, and syncthing -paths doesn’t show any log location.

Does anyone have any idea how I can rectify these two issues?

Thanks :smiley:

It’s been a few years since I touched Solaris last, but I remember SMF putting logs in specific per-service files somewhere and there being a command to get that path from svcctl…

Oh interesting,

Yeah, it’s a little confusing coming from Linux/FreeBSD - similar enough that I can get around, but different enough that I’m stumped whenever something isn’t working

Do you recommend a man page? I found this: Viewing Service Log Files - Managing System Services in Oracle® Solaris 11.2

It explains that the log files are in /var/svc/log, but they’re only for the svc instances, and I’ve been running syncthing from the command line because I can’t access the webGUI if I run syncthing as a service :confused:

Would be nice if I could figure out what’s up with syncthing.xml. Do you know if there’s a way to direct syncthing to create a log in a particular location?

Thanks :slight_smile:

No idea, sorry.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.